Elasticsearch 5.2 maven zip does not start


(Johan) #1

We have previously used elasticsearch 2.4 as an maven dependency, deploying it at nexus etc.

But, when upgrading to 5.2, we get "org.elasticsearch.bootstrap.StartupException: java.lang.IllegalStateException: Unsupported transport.type []"
If I just download the zip-file from elasticsearch website, it works as it should.

So why is there a difference between the maven repo version and the downloadable version on ES website?

org.elasticsearch.distribution.zip elasticsearch ${elasticsearch.version} zip

(David Pilato) #2

How do you start it?

With bin/elasticsearch ?


(Johan) #3

Yep, unzipped the zip file, and tried ./bin/elasticsearch

[2017-02-15T08:42:13,792][WARN ][o.e.c.l.LogConfigurator  ] ignoring unsupported logging configuration file [.../config/logging.yml], logging is configured via [...data-0-SNAPSHOT/config/log4j2.properties]
[2017-02-15T08:42:14,017][INFO ][o.e.n.Node               ] [] initializing ...
[2017-02-15T08:42:14,141][INFO ][o.e.e.NodeEnvironment    ] [znvNOTI] using [1] data paths, mounts [[/ (/dev/sda1)]], net usable_space [61.9gb], net total_space [94.3gb], spins? [possibly], types [ext4]
[2017-02-15T08:42:14,159][INFO ][o.e.e.NodeEnvironment    ] [znvNOTI] heap size [1.9gb], compressed ordinary object pointers [true]
[2017-02-15T08:42:14,163][INFO ][o.e.n.Node               ] node name [znvNOTI] derived from node ID [znvNOTIkRB-iws_KfN4e5w]; set [node.name] to override
[2017-02-15T08:42:14,165][INFO ][o.e.n.Node               ] version[5.2.0], pid[31832], build[24e05b9/2017-01-24T19:52:35.800Z], OS[Linux/4.4.0-62-generic/amd64], JVM[Oracle Corporation/Java HotSpot(TM) 64-Bit Server VM/1.8.0_91/25.91-b14]
[2017-02-15T08:42:14,200][INFO ][o.e.p.PluginsService     ] [znvNOTI] no modules loaded
[2017-02-15T08:42:14,201][INFO ][o.e.p.PluginsService     ] [znvNOTI] no plugins loaded
[2017-02-15T08:42:16,484][WARN ][o.e.b.ElasticsearchUncaughtExceptionHandler] [] uncaught exception in thread [main]
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalStateException: Unsupported transport.type []
	at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:125) ~[elasticsearch-5.2.0.jar:5.2.0]
	at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:112) ~[elasticsearch-5.2.0.jar:5.2.0]
	at org.elasticsearch.cli.SettingCommand.execute(SettingCommand.java:54) ~[elasticsearch-5.2.0.jar:5.2.0]
	at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122) ~[elasticsearch-5.2.0.jar:5.2.0]
	at org.elasticsearch.cli.Command.main(Command.java:88) ~[elasticsearch-5.2.0.jar:5.2.0]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:89) ~[elasticsearch-5.2.0.jar:5.2.0]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:82) ~[elasticsearch-5.2.0.jar:5.2.0]
Caused by: java.lang.IllegalStateException: Unsupported transport.type []
	at org.elasticsearch.common.network.NetworkModule.getTransportSupplier(NetworkModule.java:214) ~[elasticsearch-5.2.0.jar:5.2.0]
	at org.elasticsearch.node.Node.<init>(Node.java:401) ~[elasticsearch-5.2.0.jar:5.2.0]
	at org.elasticsearch.node.Node.<init>(Node.java:232) ~[elasticsearch-5.2.0.jar:5.2.0]
	at org.elasticsearch.bootstrap.Bootstrap$6.<init>(Bootstrap.java:241) ~[elasticsearch-5.2.0.jar:5.2.0]
	at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:241) ~[elasticsearch-5.2.0.jar:5.2.0]
	at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:333) ~[elasticsearch-5.2.0.jar:5.2.0]
	at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:121) ~[elasticsearch-5.2.0.jar:5.2.0]
	... 6 more

(David Pilato) #4

That's strange. I need to check but I'm doing something similar as you do here:

And this is working for me.

Can you share a bit more details on what you are doing? I mean a pom file or anything like this.


(Johan) #5

I found what was wrong.. When unpacking, I did not unpack /modules.

[2017-02-15T10:39:32,243][INFO ][o.e.b.BootstrapChecks ] [ncYOf4b] bound or publishing to a non-loopback or non-link-local address, enforcing bootstrap checks
[2017-02-15T10:39:32,250][ERROR][o.e.b.Bootstrap ] [ncYOf4b] node validation exception
bootstrap checks failed
initial heap size [1073741824] not equal to maximum heap size [2147483648]; this can cause resize pauses and prevents mlockall from locking the entire heap
max file descriptors [32768] for elasticsearch process is too low, increase to at least [65536]
max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]
system call filters failed to install; check the logs and fix your configuration or disable system call filters at your own risk
[2017-02-15T10:39:32,252][INFO ][o.e.n.Node ] [ncYOf4b] stopping ...
[2017-02-15T10:39:32,274][INFO ][o.e.n.Node ] [ncYOf4b] stopped
[2017-02-15T10:39:32,274][INFO ][o.e.n.Node ] [ncYOf4b] closing ...
[2017-02-15T10:39:32,292][INFO ][o.e.n.Node ] [ncYOf4b] closed

transport.tcp.port: ${transport.tcp.port}
#
# Set a custom port for HTTP:
#
#https://www.elastic.co/guide/en/elasticsearch/reference/current/modules-http.html
http.port: ${http.port}
http.compression: true

#https://www.elastic.co/guide/en/elasticsearch/reference/current/modules-network.html
network.bind_host: _site_, _local_
network.publish_host: _site_
#
# For more information, consult the network module documentation.
#
# --------------------------------- Discovery ----------------------------------
#
# Pass an initial list of hosts to perform discovery when new node is started:
# The default list of hosts is ["127.0.0.1", "[::1]"]
#
discovery.zen.ping.unicast.hosts: {$elasticsearch.master.nodes.binary}

(David Pilato) #6

So now you "just" need to solve the bootstrap checks. I think we can mark this one as solved...


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.