Elasticsearch 7.9.2 stuck at startip

I m trying to install elasticsearch 7.9.2 using cloudformation on AWS Ec2. When i run command
"service elasticsearch start" in cloudformation cfn-init command it never completes even though elasticsearch has started.
service elasticsearch start completes when run manually.

cant find any logs or errors. This is happening after version > = 7.7.0 , It is working fine in version 7.4.2

What do the Elasticsearch logs show?

No errors, nothings.. elasticsearch is up and running it is just at service elasticsearch start doesnt complete. Installed using rpm

What about journalctl -xe -u elasticsearch, can you see any logs inside?

cant find it installed on the system itself.

I believe it is something to do with sd_notify in elasticsearch but could not find any logs

Could see node is initialized log ...but still command service elasticsearch start is running

I could see whenever i run service elasticsearch start from cfn-init and main process never receives complete signal

Hi Deepansh, please share some logs as it is difficult to understand what is going on.