Elasticsearch 7 and JVM 21

I noticed that elasticsearch 7.17.15 comes with bundled JDK 21.0.1.
But in Support Matrix | Elastic in documentation, JDK 21 is not listed as supported.
Is it an inaccuracy in the Support Matrix and should I consider JDK 21 as supported?
Thank you.

Thank you for reporting this. Let me check and get back to you.

@dadoonet, any updates on this please?
Thank you very much.

You could consider JDK21 as supported.
The matrix will be updated when 8.13 will be released.