Elasticsearch cache configuration


(Hediye Delkhosh) #1

Hello.
I've installed Elasticsearch on web server and it use most part of memory,
I searched and finally found cache module and it's configuration but I
don't know how config Elasticsearch. Where should I insert below
configurations???

index.cache.field.max_size: 50000
index.cache.field.expire: 10m
index.cache.field.type: soft

should I enabale Cache module?? and where??

Thank you so much :slight_smile:

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/0fcf6faf-caf2-4b16-b4b3-249ffc4cee4f%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Binh Ly-2) #2

For ES 1.0, the field data settings are here:

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/index-modules-fielddata.html

The filter cache settings are here:

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/index-modules-cache.html

The easiest way is to set these in the elasticsearch.yml file.

I would caution that you'll probably need to first investigate and
understand your memory usage before trying to change any of these settings.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/9b5779a7-8839-42d4-af20-1d9b720ff242%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Hediye Delkhosh) #3

@Binh Ly thank you for reply.
I don't know where should I insert this configs.
I've installes FOS-elastica in my project, there is a elasticsearch.yml in
my project and another one is in /etc/elasticsearch. where should I insert
configs?

I've tested server memory usage. Elasticserach service use memory alot.

Thank you :slight_smile:

On Wednesday, February 26, 2014 6:29:04 PM UTC+3:30, Binh Ly wrote:

For ES 1.0, the field data settings are here:

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/index-modules-fielddata.html

The filter cache settings are here:

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/index-modules-cache.html

The easiest way is to set these in the elasticsearch.yml file.

I would caution that you'll probably need to first investigate and
understand your memory usage before trying to change any of these settings.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/7ebf2e93-7f38-47fc-9cc0-c1eee98e60c2%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Zachary Tong) #4

If you simply want to decrease the amount of memory that Elasticsearch is
using, you need to change your heap size (via the HEAP_SIZE environment
variable). That controls the total memory allocated to Elasticsearch.

Echoing what Binh said...try not to change the field-data settings unless
you know what you are doing. You should not enable soft references for
field-data, this is a very bad option. It causes excessive GC thrashing
and is not needed (especially now that 1.0 has circuit breaker logic built
in). Similarly, the time expiration on field-data is typically a poor
option, since it unnecessarily thrashes the GC too.

On Wednesday, February 26, 2014 10:19:40 AM UTC-5, Hediye Delkhosh wrote:

@Binh Ly thank you for reply.
I don't know where should I insert this configs.
I've installes FOS-elastica in my project, there is a elasticsearch.yml in
my project and another one is in /etc/elasticsearch. where should I insert
configs?

I've tested server memory usage. Elasticserach service use memory alot.

Thank you :slight_smile:

On Wednesday, February 26, 2014 6:29:04 PM UTC+3:30, Binh Ly wrote:

For ES 1.0, the field data settings are here:

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/index-modules-fielddata.html

The filter cache settings are here:

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/index-modules-cache.html

The easiest way is to set these in the elasticsearch.yml file.

I would caution that you'll probably need to first investigate and
understand your memory usage before trying to change any of these settings.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/325c57fb-7cef-4805-8708-c59ef14f6d73%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Mark Walkom) #5

Configuration settings go in your elasticsearch.yml file.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 27 February 2014 02:51, Zachary Tong zacharyjtong@gmail.com wrote:

If you simply want to decrease the amount of memory that Elasticsearch is
using, you need to change your heap size (via the HEAP_SIZE environment
variable). That controls the total memory allocated to Elasticsearch.

Echoing what Binh said...try not to change the field-data settings unless
you know what you are doing. You should not enable soft references for
field-data, this is a very bad option. It causes excessive GC thrashing
and is not needed (especially now that 1.0 has circuit breaker logic built
in). Similarly, the time expiration on field-data is typically a poor
option, since it unnecessarily thrashes the GC too.

On Wednesday, February 26, 2014 10:19:40 AM UTC-5, Hediye Delkhosh wrote:

@Binh Ly thank you for reply.
I don't know where should I insert this configs.
I've installes FOS-elastica in my project, there is a elasticsearch.yml
in my project and another one is in /etc/elasticsearch. where should I
insert configs?

I've tested server memory usage. Elasticserach service use memory alot.

Thank you :slight_smile:

On Wednesday, February 26, 2014 6:29:04 PM UTC+3:30, Binh Ly wrote:

For ES 1.0, the field data settings are here:

http://www.elasticsearch.org/guide/en/elasticsearch/
reference/current/index-modules-fielddata.html

The filter cache settings are here:

http://www.elasticsearch.org/guide/en/elasticsearch/
reference/current/index-modules-cache.html

The easiest way is to set these in the elasticsearch.yml file.

I would caution that you'll probably need to first investigate and
understand your memory usage before trying to change any of these settings.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/325c57fb-7cef-4805-8708-c59ef14f6d73%40googlegroups.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624ZFCJxuRZWZsg69tmHcWmFX0bn5YBxjHAqTS%2BMYirHYeA%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #6