Elasticsearch client node and cluster


(Amin) #1

hi

this is result of my cluster :

[root@es-client-01 ~]# curl -XGET 'http://172.24.69.13:9200/_cat/nodes?pretty=true'
172.24.69.17 19 74 0 0.00 0.01 0.05 di - es-data-02
172.24.69.19 16 74 0 0.00 0.01 0.05 mi * es-master-01
172.24.69.18 14 73 0 0.00 0.01 0.05 di - es-data-03
172.24.69.20 12 75 0 0.00 0.01 0.05 mi - es-master-02
172.24.69.16 11 76 0 0.04 0.03 0.05 di - es-data-01
172.24.69.13 10 75 27 0.22 0.06 0.06 i - es-client-01
172.24.69.14 17 76 0 0.00 0.01 0.05 i - es-client-02

I am using elasticesearch version 5.3.0
now I have 3 problem :
1 - recently config of client node is :

---------------------------------- Cluster -----------------------------------

Use a descriptive name for your cluster:

cluster.name: logserver

node.name: es-client-01
#node.client: true
node.master: false
node.data: false

network.host: 172.24.69.13

#discovery.zen.ping.multicast.enable: false

discovery.zen.ping.unicast.hosts: ["172.24.69.16","172.24.69.17","172.24.69.18","172.24.69.19","172.24.69.20","172.24.69.13","172.24.69.14"]

when I enable node.client: true then elasticsearch not work

2- when I enable discovery.zen.ping.multicast.enable to true in all servers and nods, then elasticsearch status became Faild

3- How can I use to client node in my cluster and how my to logstash can send log to my client nodes :


(Mark Walkom) #2

What does that mean? How does it fail?


(Amin) #3

dear warkolm

i found that in elasticsearch 2.4 we have client node and in 5.3 we have coordinating node and i must set master,data and Ingest to false

now need to config logstash output to send data to two coordinating node, please help me in this field
tahnks


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.