Elasticsearch Cluster - no node visible

Hi
System: CentOS 8 Stream
Elasticsearch ver: 8.1.0
Nodes:

node1.test.com 192.168.100.101
node2.test.com 192.168.100.102
node3.test.com 192.168.100.103

All nodes can be pinged by IP and FQDN, Firewalld has open ports 9200 / tcp, 9300 / tcp on all hosts.
Config:

/etc/Elasticsearch/Elasticsearch.yml

cluster.name: elastic-cluster
node.name: ${HOSTNAME}
path.data: /var/lib/elasticsearch
path.logs: /var/log/elasticsearch
network.host: 0.0.0.0
http.port: 9200
discovery.seed_hosts: ["node1.test.com", "node2.test.com", "node3.test.com"]
cluster.initial_master_nodes: ["node1.test.com", "node2.test.com", "node3.test.com"]

After configuring the Elasticsearch.yml file (the same on each host), the following was done:
# systemctl enable --now elasticsearch

Command:
# curl http://192.168.100.101:9200/_cat/nodes?v
returns:

ip heap.percent ram.percent cpu load_1m load_5m load_15m node.role master name
192.168.100.101 15 95 54 0.01 0.59 1.20 cdfhilmrstw * node1.test.com

Does not show the remaining 2 nodes

Command:
# curl http://192.168.100.101:9200/_cluster/health?pretty
Returns:

{
"cluster_name": "elastic-cluster",
"status": "green",
"timed_out": false,
"number_of_nodes": 1, (and should be 3)
"number_of_data_nodes": 1, (and should be 3)
"active_primary_shards": 3,
"active_shards": 3,
"relocating_shards": 0,
"initializing_shards": 0,
"unassigned_shards": 0,
"delayed_unassigned_shards": 0,
"number_of_pending_tasks": 0,
"number_of_in_flight_fetch": 0,
"task_max_waiting_in_queue_millis": 0,
"active_shards_percent_as_number": 100.0
}

Can you ask for help in solving the problem? The system (on all nodes) was installed from scratch in one of the attempts, and only Elasticsearch was installed on it.

The solution is very easy!
Turn off all nodes that are part of the cluster.
Then delete all data (files, directories) from the location specified in [Elasticsearch.yml] as [path.data =].
In my case, these are respectively:
[/etc/Elasticsearch/Elasticsearch.yml]
path.data = / var / lib / Elasticsearch
Then we restart individual cluster nodes.
In my case, that solved the problem.
Greetings :slight_smile:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.