Elasticsearch cluster state is yellow

I have a 3 node cluster and i have set minimum master node to 1. My cluster was working fine these days. But now i am a find a issue, that whatever new index i create other than .kibana all are in yellow state. When i try to reroute the index i get the following error message.

"reason" : "[allocate_replica] allocation of [smarts-historical][0] on node {node2}{fBUkdNQ1StCKR0xq5AwV8A}{c_SuNyGARhWKXLuoBtgKQA}{lonlalkibsrv01}{} is not allowed, reason: [YES(shard has no previous failures)][YES(primary shard for this replica is already active)][YES(explicitly ignoring any disabling of allocation due to manual allocation commands via the reroute API)][NO(target node version [5.5.1] is older than the source node version [5.6.2])][YES(the shard is not being snapshotted)][YES(node passes include/exclude/require filters)][YES(the shard does not exist on the same node)][YES(enough disk for shard on node, free: [51.6gb], shard size: [0b], free after allocating shard: [51.6gb])][YES(below shard recovery limit of outgoing: [0 < 2] incoming: [0 < 2])][YES(total shard limits are disabled: [index: -1, cluster: -1] <= 0)][YES(allocation awareness is not enabled, set cluster setting [cluster.routing.allocation.awareness.attributes] to enable it)]"

I tried searching for disk usage and found /usr is used more than 15%, will that be a reason.

It looks like the nodes in your cluster are not all running exactly the same version of Elasticsearch, which will prevent replicas being generated or moved to older nodes. Upgrade nodes with older versions to rectify this. Also review your config to make sure you have minimum_master_nodes set correctly to avoid split-brain scenarios.

Thanks for the help. One of the nodes in the cluster is upgraded.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.