Elasticsearch clusters and nodes


I am trying to set up the elasticsearch clusters and nodes, where I have updated the below changes on elasticsearch.yml file: (I think I have a problem with the Unicast Discovery below):

Master Node:
node.master: true
node.data: false

Data Node:
node.master: false
node.data: true

Client Node:
node.master: false
node.data: false

Tribe Nodes:
tribe.cluster1.eshadoopcluster: eshadoopcluster1-name
tribe.cluster2.eshadoopcluster: eshadoopcluster2-name

Multicast Discovery:

#Could someone help me with this part. How it should be updated
Unicast Discovery:
discovery.zen.ping.unicast.hosts: ["node1:9300","node2:9300", "node3:[9300-9400]"]

The above Unicast Discovery is where I am facing the issue.

discovery.zen.ping.unicast.hosts needs to be set to a small number of hosts that can be used as seeds to first connect to when the node joins the cluster. You can set this so a small number of any of your client, data or maters nodes but typically users will add their master nodes in this array. The format of the entries int he array should be $hostname:$transport.tcp.port usually the $transport.tcp.port is 9300, more information on this can be found here: https://www.elastic.co/guide/en/elasticsearch/reference/5.4/important-settings.html#unicast.hosts


Thanks for your response. I've tried what you said as below:

discovery.zen.ping.unicast.hosts: ["localhost:9300"]

And it gives me the below error when I run elasticsearch.

[eshadoop@localhost elasticsearch]$ sudo ./bin/elasticsearch
[2017-06-28 11:53:44,348][INFO ][node                     ] [ES Hadoop Node] version[1.7.1], pid[75522], build[b88f43f/2015-07-29T09:54:16Z]
[2017-06-28 11:53:44,348][INFO ][node                     ] [ES Hadoop Node] initializing ...
[2017-06-28 11:53:44,397][INFO ][plugins                  ] [ES Hadoop Node] loaded [marvel], sites [marvel, head]
[2017-06-28 11:53:45,925][INFO ][node                     ] [ES Hadoop Node/cluster1] version[1.7.1], pid[75522], build[b88f43f/2015-07-29T09:54:16Z]
[2017-06-28 11:53:45,925][INFO ][node                     ] [ES Hadoop Node/cluster1] initializing ...
[2017-06-28 11:53:45,926][INFO ][plugins                  ] [ES Hadoop Node/cluster1] loaded [marvel], sites [marvel, head]
[2017-06-28 11:53:46,610][INFO ][node                     ] [ES Hadoop Node/cluster1] initialized
[2017-06-28 11:53:46,610][INFO ][node                     ] [ES Hadoop Node/cluster2] version[1.7.1], pid[75522], build[b88f43f/2015-07-29T09:54:16Z]
[2017-06-28 11:53:46,611][INFO ][node                     ] [ES Hadoop Node/cluster2] initializing ...
[2017-06-28 11:53:46,612][INFO ][plugins                  ] [ES Hadoop Node/cluster2] loaded [marvel], sites [marvel, head]
[2017-06-28 11:53:47,166][INFO ][node                     ] [ES Hadoop Node/cluster2] initialized
[2017-06-28 11:53:47,176][INFO ][node                     ] [ES Hadoop Node] initialized
[2017-06-28 11:53:47,176][INFO ][node                     ] [ES Hadoop Node] starting ...
[2017-06-28 11:53:47,260][INFO ][transport                ] [ES Hadoop Node] bound_address {inet[/0:0:0:0:0:0:0:0:9300]}, publish_address {inet[/]}
[2017-06-28 11:53:47,267][INFO ][discovery                ] [ES Hadoop Node] eshadoopcluster/8rmWp4bUQjqjsxElHaYwXw
[2017-06-28 11:53:47,267][WARN ][discovery                ] [ES Hadoop Node] waited for 0s and no initial state was set by the discovery
[2017-06-28 11:53:47,267][INFO ][node                     ] [ES Hadoop Node/cluster1] starting ...
[2017-06-28 11:53:47,327][INFO ][transport                ] [ES Hadoop Node/cluster1] bound_address {inet[/0:0:0:0:0:0:0:0:9301]}, publish_address {inet[/]}
[2017-06-28 11:53:47,338][INFO ][discovery                ] [ES Hadoop Node/cluster1] elasticsearch/_TRs3faeR6um_yQUYi52pw
[2017-06-28 11:53:57,194][WARN ][marvel.agent.exporter    ] [ES Hadoop Node] http server is not enabled no hosts are manually configured
[2017-06-28 11:54:07,198][WARN ][marvel.agent.exporter    ] [ES Hadoop Node] http server is not enabled no hosts are manually configured
[2017-06-28 11:54:17,201][WARN ][marvel.agent.exporter    ] [ES Hadoop Node] http server is not enabled no hosts are manually configured

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.