Elasticsearch connecition


(Hilal) #1

Hi,
I installed ES-5.0.0 and Kibana-5.0.0. I started ES. It worked true.

After I installed another programs (X-PACK, PHP CLIENT etc.) and I restart ES but it is not working.

My ES logs:

[2016-11-08T16:29:21,432][ERROR][o.e.b.Bootstrap          ] [NchqMHF] node validation exception
bootstrap checks failed
max number of threads [1024] for user [elasticsearch] likely too low, increase to at least [2048]
[2016-11-08T16:29:21,441][INFO ][o.e.n.Node               ] [NchqMHF] stopping ...
[2016-11-08T16:29:21,481][INFO ][o.e.n.Node               ] [NchqMHF] stopped
[2016-11-08T16:29:21,481][INFO ][o.e.n.Node               ] [NchqMHF] closing ...
[2016-11-08T16:29:21,490][INFO ][o.e.n.Node               ] [NchqMHF] closed
[2016-11-08T16:34:18,876][WARN ][o.e.b.JNANatives         ] unable to install syscall filter: 
java.lang.UnsupportedOperationException: seccomp unavailable: CONFIG_SECCOMP not compiled into kernel, CONFIG_SECCOMP and CONFIG_SECCOMP_FILTER are needed
    at org.elasticsearch.bootstrap.Seccomp.linuxImpl(Seccomp.java:361) ~[elasticsearch-5.0.0.jar:5.0.0]
    at org.elasticsearch.bootstrap.Seccomp.init(Seccomp.java:630) ~[elasticsearch-5.0.0.jar:5.0.0]
    at org.elasticsearch.bootstrap.JNANatives.trySeccomp(JNANatives.java:215) [elasticsearch-5.0.0.jar:5.0.0]
    at org.elasticsearch.bootstrap.Natives.trySeccomp(Natives.java:99) [elasticsearch-5.0.0.jar:5.0.0]
    at org.elasticsearch.bootstrap.Bootstrap.initializeNatives(Bootstrap.java:101) [elasticsearch-5.0.0.jar:5.0.0]
    at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:155) [elasticsearch-5.0.0.jar:5.0.0]
    at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:286) [elasticsearch-5.0.0.jar:5.0.0]
    at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:112) [elasticsearch-5.0.0.jar:5.0.0]
    at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:103) [elasticsearch-5.0.0.jar:5.0.0]
    at org.elasticsearch.cli.SettingCommand.execute(SettingCommand.java:54) [elasticsearch-5.0.0.jar:5.0.0]
    at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:96) [elasticsearch-5.0.0.jar:5.0.0]
    at org.elasticsearch.cli.Command.main(Command.java:62) [elasticsearch-5.0.0.jar:5.0.0]
    at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:80) [elasticsearch-5.0.0.jar:5.0.0]
    at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:73) [elasticsearch-5.0.0.jar:5.0.0]

(Hilal) #2

and more logs...

 [2016-11-08T16:34:18,995][INFO ][o.e.n.Node               ] [] initializing ...
    [2016-11-08T16:34:19,078][INFO ][o.e.e.NodeEnvironment    ] [NchqMHF] using [1] data paths, mounts [[/ (/dev/mapper/VolGroup-lv_root)]], net usable_space [31.1gb], net total_space [49gb], spins? [no], types [ext4]
    [2016-11-08T16:34:19,079][INFO ][o.e.e.NodeEnvironment    ] [NchqMHF] heap size [1.9gb], compressed ordinary object pointers [true]
    [2016-11-08T16:34:19,097][INFO ][o.e.n.Node               ] [NchqMHF] node name [NchqMHF] derived from node ID; set [node.name] to override
    [2016-11-08T16:34:19,100][INFO ][o.e.n.Node               ] [NchqMHF] version[5.0.0], pid[4139], build[253032b/2016-10-26T04:37:51.531Z], OS[Linux/2.6.32-642.6.2.el6.x86_64/amd64], JVM[Oracle Corporation/OpenJDK 64-Bit Server VM/1.8.0_111/25.111-b15]
    [2016-11-08T16:34:20,641][INFO ][o.e.p.PluginsService     ] [NchqMHF] loaded module [aggs-matrix-stats]
    [2016-11-08T16:34:20,641][INFO ][o.e.p.PluginsService     ] [NchqMHF] loaded module [ingest-common]
    [2016-11-08T16:34:20,641][INFO ][o.e.p.PluginsService     ] [NchqMHF] loaded module [lang-expression]
    [2016-11-08T16:34:20,641][INFO ][o.e.p.PluginsService     ] [NchqMHF] loaded module [lang-groovy]
    [2016-11-08T16:34:20,641][INFO ][o.e.p.PluginsService     ] [NchqMHF] loaded module [lang-mustache]
    [2016-11-08T16:34:20,641][INFO ][o.e.p.PluginsService     ] [NchqMHF] loaded module [lang-painless]
    [2016-11-08T16:34:20,641][INFO ][o.e.p.PluginsService     ] [NchqMHF] loaded module [percolator]
    [2016-11-08T16:34:20,642][INFO ][o.e.p.PluginsService     ] [NchqMHF] loaded module [reindex]
    [2016-11-08T16:34:20,642][INFO ][o.e.p.PluginsService     ] [NchqMHF] loaded module [transport-netty3]
    [2016-11-08T16:34:20,642][INFO ][o.e.p.PluginsService     ] [NchqMHF] loaded module [transport-netty4]
    [2016-11-08T16:34:20,642][INFO ][o.e.p.PluginsService     ] [NchqMHF] loaded plugin [x-pack]
    [2016-11-08T16:34:23,264][INFO ][o.e.n.Node               ] [NchqMHF] initialized
    [2016-11-08T16:34:23,265][INFO ][o.e.n.Node               ] [NchqMHF] starting ...
    [2016-11-08T16:34:23,523][INFO ][o.e.t.TransportService   ] [NchqMHF] publish_address {127.0.0.1:9300}, bound_addresses {[::1]:9300}, {127.0.0.1:9300}, {[::2]:9300}
    [2016-11-08T16:34:23,528][INFO ][o.e.b.BootstrapCheck     ] [NchqMHF] bound or publishing to a non-loopback or non-link-local address, enforcing bootstrap checks

(Hilal) #3

I tried to connect from the http://localhost:9200/ but not connected.


(evert) #4

Did you use the user and password standard for the x-pack to access your ES server with http://localhost:9200?


(David Pilato) #5

+1

All logs are correct.


(Hilal) #6

yes I used.

username:elastic
passw:changeme

and after I changed the password on kibana and it did not work


(Hilal) #7

When I start ES it worked true.
I tried connect:

http://localhost:9200/

It didn't connect. I don't understand.


(David Pilato) #8

Can we have the rest of your logs please?


(Hilal) #9

ok. I cleaned my log file and I restart ES-5.0.0.

My logs:

[2016-11-08T17:41:07,370][WARN ][o.e.b.JNANatives         ] unable to install syscall filter: 
java.lang.UnsupportedOperationException: seccomp unavailable: CONFIG_SECCOMP not compiled into kernel, CONFIG_SECCOMP and CONFIG_SECCOMP_FILTER are needed
    at org.elasticsearch.bootstrap.Seccomp.linuxImpl(Seccomp.java:361) ~[elasticsearch-5.0.0.jar:5.0.0]
    at org.elasticsearch.bootstrap.Seccomp.init(Seccomp.java:630) ~[elasticsearch-5.0.0.jar:5.0.0]
    at org.elasticsearch.bootstrap.JNANatives.trySeccomp(JNANatives.java:215) [elasticsearch-5.0.0.jar:5.0.0]
    at org.elasticsearch.bootstrap.Natives.trySeccomp(Natives.java:99) [elasticsearch-5.0.0.jar:5.0.0]
    at org.elasticsearch.bootstrap.Bootstrap.initializeNatives(Bootstrap.java:101) [elasticsearch-5.0.0.jar:5.0.0]
    at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:155) [elasticsearch-5.0.0.jar:5.0.0]
    at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:286) [elasticsearch-5.0.0.jar:5.0.0]
    at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:112) [elasticsearch-5.0.0.jar:5.0.0]
    at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:103) [elasticsearch-5.0.0.jar:5.0.0]
    at org.elasticsearch.cli.SettingCommand.execute(SettingCommand.java:54) [elasticsearch-5.0.0.jar:5.0.0]
    at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:96) [elasticsearch-5.0.0.jar:5.0.0]
    at org.elasticsearch.cli.Command.main(Command.java:62) [elasticsearch-5.0.0.jar:5.0.0]
    at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:80) [elasticsearch-5.0.0.jar:5.0.0]
    at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:73) [elasticsearch-5.0.0.jar:5.0.0]
[2016-11-08T17:41:07,473][INFO ][o.e.n.Node               ] [] initializing ...
[2016-11-08T17:41:07,555][INFO ][o.e.e.NodeEnvironment    ] [NchqMHF] using [1] data paths, mounts [[/ (/dev/mapper/VolGroup-lv_root)]], net usable_space [31.1gb], net total_space [49gb], spins? [no], types [ext4]
[2016-11-08T17:41:07,555][INFO ][o.e.e.NodeEnvironment    ] [NchqMHF] heap size [1.9gb], compressed ordinary object pointers [true]
[2016-11-08T17:41:07,567][INFO ][o.e.n.Node               ] [NchqMHF] node name [NchqMHF] derived from node ID; set [node.name] to override
[2016-11-08T17:41:07,568][INFO ][o.e.n.Node               ] [NchqMHF] version[5.0.0], pid[5151], build[253032b/2016-10-26T04:37:51.531Z], OS[Linux/2.6.32-642.6.2.el6.x86_64/amd64], JVM[Oracle Corporation/OpenJDK 64-Bit Server VM/1.8.0_111/25.111-b15]
[2016-11-08T17:41:08,902][INFO ][o.e.p.PluginsService     ] [NchqMHF] loaded module [aggs-matrix-stats]
[2016-11-08T17:41:08,903][INFO ][o.e.p.PluginsService     ] [NchqMHF] loaded module [ingest-common]
[2016-11-08T17:41:08,903][INFO ][o.e.p.PluginsService     ] [NchqMHF] loaded module [lang-expression]
[2016-11-08T17:41:08,903][INFO ][o.e.p.PluginsService     ] [NchqMHF] loaded module [lang-groovy]
[2016-11-08T17:41:08,903][INFO ][o.e.p.PluginsService     ] [NchqMHF] loaded module [lang-mustache]
[2016-11-08T17:41:08,903][INFO ][o.e.p.PluginsService     ] [NchqMHF] loaded module [lang-painless]
[2016-11-08T17:41:08,903][INFO ][o.e.p.PluginsService     ] [NchqMHF] loaded module [percolator]
[2016-11-08T17:41:08,903][INFO ][o.e.p.PluginsService     ] [NchqMHF] loaded module [reindex]
[2016-11-08T17:41:08,903][INFO ][o.e.p.PluginsService     ] [NchqMHF] loaded module [transport-netty3]
[2016-11-08T17:41:08,903][INFO ][o.e.p.PluginsService     ] [NchqMHF] loaded module [transport-netty4]
[2016-11-08T17:41:08,903][INFO ][o.e.p.PluginsService     ] [NchqMHF] loaded plugin [x-pack]
[2016-11-08T17:41:11,282][INFO ][o.e.n.Node               ] [NchqMHF] initialized
[2016-11-08T17:41:11,282][INFO ][o.e.n.Node               ] [NchqMHF] starting ...
[2016-11-08T17:41:11,540][INFO ][o.e.t.TransportService   ] [NchqMHF] publish_address {127.0.0.1:9300}, bound_addresses {[::1]:9300}, {127.0.0.1:9300}, {[::2]:9300}
[2016-11-08T17:41:11,544][INFO ][o.e.b.BootstrapCheck     ] [NchqMHF] bound or publishing to a non-loopback or non-link-local address, enforcing bootstrap checks
[2016-11-08T17:41:11,546][ERROR][o.e.b.Bootstrap          ] [NchqMHF] node validation exception
bootstrap checks failed
max number of threads [1024] for user [elasticsearch] likely too low, increase to at least [2048]
[2016-11-08T17:41:11,548][INFO ][o.e.n.Node               ] [NchqMHF] stopping ...
[2016-11-08T17:41:11,584][INFO ][o.e.n.Node               ] [NchqMHF] stopped
[2016-11-08T17:41:11,584][INFO ][o.e.n.Node               ] [NchqMHF] closing ...
[2016-11-08T17:41:11,593][INFO ][o.e.n.Node               ] [NchqMHF] closed

Connect to elastic Search from public ip
(David Pilato) #10

You need to fix that:

[2016-11-08T17:41:11,546][ERROR][o.e.b.Bootstrap          ] [NchqMHF] node validation exception
bootstrap checks failed
max number of threads [1024] for user [elasticsearch] likely too low, increase to at least [2048]

Look at the doc. It explains all that.


(evert) #11

@dadoonet is right...

Check here.


(Hilal) #15

I installed ES-5.0.0 rpm package. So I have to use system configuration file. (https://www.elastic.co/guide/en/elasticsearch/reference/master/setting-system-settings.html#ulimit)

It says,

When using the RPM or Debian packages, system settings and environment variables can be specified in the system configuration file, which is located in:

RPM

/etc/sysconfig/elasticsearch

Debian

/etc/default/elasticsearch

However, for systems which uses systemd, system limits need to be specified via systemd.

elasticsearch file: (/etc/sysconfig/elasticsearch)

################################
# Elasticsearch
################################

# Elasticsearch home directory
#ES_HOME=/usr/share/elasticsearch

# Elasticsearch Java path
#JAVA_HOME=

# Elasticsearch configuration directory
#CONF_DIR=/etc/elasticsearch

# Elasticsearch data directory
#DATA_DIR=/var/lib/elasticsearch

# Elasticsearch logs directory
#LOG_DIR=/var/log/elasticsearch

# Elasticsearch PID directory
#PID_DIR=/var/run/elasticsearch

# Additional Java OPTS
#ES_JAVA_OPTS=

# Configure restart on package upgrade (true, every other setting will lead to not restarting)
#RESTART_ON_UPGRADE=true

################################
# Elasticsearch service
################################

# SysV init.d
#
# When executing the init script, this user will be used to run the elasticsearch service.
# The default value is 'elasticsearch' and is declared in the init.d file.
# Note that this setting is only used by the init script. If changed, make sure that
# the configured user can read and write into the data, work, plugins and log directories.
# For systemd service, the user is usually configured in file /usr/lib/systemd/system/elasticsearch.service
#ES_USER=elasticsearch
#ES_GROUP=elasticsearch

# The number of seconds to wait before checking if Elasticsearch started successfully as a daemon process
ES_STARTUP_SLEEP_TIME=5

################################
# System properties
################################

# Specifies the maximum file descriptor number that can be opened by this process
# When using Systemd, this setting is ignored and the LimitNOFILE defined in
# /usr/lib/systemd/system/elasticsearch.service takes precedence
#MAX_OPEN_FILES=65536

# The maximum number of bytes of memory that may be locked into RAM
# Set to "unlimited" if you use the 'bootstrap.memory_lock: true' option
# in elasticsearch.yml.
# When using Systemd, the LimitMEMLOCK property must be set
# in /usr/lib/systemd/system/elasticsearch.service
#MAX_LOCKED_MEMORY=unlimited

# Maximum number of VMA (Virtual Memory Areas) a process can own
# When using Systemd, this setting is ignored and the 'vm.max_map_count'
# property is set at boot time in /usr/lib/sysctl.d/elasticsearch.conf
#MAX_MAP_COUNT=262144

I did not see anything wrong here. What is the problem?


(Hilal) #16

I changed my elasticsearch.yml file.
I had an old elasticsearch.yml file(ES-2.4.1).
I replace my ES-2.4.1 elasticsearch.yml file with ES-5.0.0 elasticsearch.yml.
It connected . (http://localhost:9200)
I think The problem is in the elastic search.yml file

Problem solved
Thanks anyway.


(system) #17

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.