Elasticsearch coordinating node gc.log

Hi All,

I have a 3 node elasticsearch cluster.
I'm connecting my Kibana to this cluster through elasticsearch coordinating node

The elasticsearch coordinating node and kibana is running on the same server.

For my coordinating node I can see every minute:

[2020-03-25T13:56:25.342+0000][20967][gc,start     ] GC(0) Pause Young (Allocation Failure)
[2020-03-25T13:56:25.343+0000][20967][gc,task      ] GC(0) Using 4 workers of 4 for evacuation
[2020-03-25T13:56:25.359+0000][20967][gc,age       ] GC(0) Desired survivor size 17432576 bytes, new threshold 6 (max threshold 6)
[2020-03-25T13:56:25.359+0000][20967][gc,age       ] GC(0) Age table with threshold 6 (max threshold 6)
[2020-03-25T13:56:25.360+0000][20967][gc,age       ] GC(0) - age   1:   12866528 bytes,   12866528 total
[2020-03-25T13:56:25.360+0000][20967][gc,heap      ] GC(0) ParNew: 272640K->12716K(306688K)
[2020-03-25T13:56:25.360+0000][20967][gc,heap      ] GC(0) CMS: 0K->0K(1756416K)
[2020-03-25T13:56:25.360+0000][20967][gc,metaspace ] GC(0) Metaspace: 20258K->20258K(1067008K)
[2020-03-25T13:56:25.360+0000][20967][gc           ] GC(0) Pause Young (Allocation Failure) 266M->12M(2014M) 17.420ms
[2020-03-25T13:56:25.360+0000][20967][gc,cpu       ] GC(0) User=0.04s Sys=0.00s Real=0.02s

If my understanding is correct regarding GC(0) Pause Young (Allocation Failure), there is not enough memory to properly work.

How should I change the java memory settings to avoid allocation failure?

my ES coordinating node configuration

cluster.name: $myclustername
path.data: /var/lib/elasticsearch
path.logs: /var/log/elasticsearch
network.host: localhost
http.port: 9200
transport.host: $hostipaddress
transport.tcp.port: 9300
discovery.seed_hosts: ["$hostarelistedhere"]
xpack.security.enabled: true
xpack.security.transport.ssl.enabled: true
xpack.security.transport.ssl.verification_mode: certificate
xpack.security.transport.ssl.keystore.path: /etc/elasticsearch/elastic-certificates.p12
xpack.security.transport.ssl.truststore.path: /etc/elasticsearch/elastic-certificates.p12
node.master: false
node.data: false
node.ingest: false
node.ml: false

Thanks,
Andras

This is normal behaviour. I don't think there's anything to worry about if you're seeing a 0.02s GC every minute.

1 Like

I had to update my knowledge for Java13. Since java9 lot of things changed regarding GC.

Thanks.