Elasticsearch 起動後のcurlを使った正常性確認でエラー

基本的がわかっておらず恐縮ですがご教授ください。
linux(Ubuntu)でbin/elasticsearchでelasticsearchを起動した後、
別のシェルからcurl http://localhost:9200と打つと

ERROR
 
ページを表示できません
 

といったような表示が出てしまいます。一方、ブラウザでhttp://localhost:9200/ で確認すると、正常に
{
"name" : "nekamodel",
"cluster_name" : "elasticsearch",
"cluster_uuid" : "Z4NTsl-7QiabAzkC7ZfobQ",
"version" : {
"number" : "7.0.0",
"build_flavor" : "default",
"build_type" : "tar",
"build_hash" : "b7e28a7",
"build_date" : "2019-04-05T22:55:32.697037Z",
"build_snapshot" : false,
"lucene_version" : "8.0.0",
"minimum_wire_compatibility_version" : "6.7.0",
"minimum_index_compatibility_version" : "6.0.0-beta1"
},
"tagline" : "You Know, for Search"
}

と表示されます。windowsでELK6.5を試していた時にはこのようなことは発生していませんでした。
私がlinuxが慣れてないからなのかもしれませんが原因についてわかりますでしょうか?

サーバーに接続できません。
サーバーが存在しないか、接続拒否している可能性があります。

すみません、エラー表示のHTML文をそのままコピーしたら表示されませんでした。失礼しました。
エラーの文言としては、

・ページを表示できません
・サーバーに接続できません。
・サーバーが存在しないか、接続拒否している可能性があります。

という文言が入ってきます。
よろしくお願い致します。

すみません。自分なりに調べてうまくいくことができました。原因は
elasticsearch.yaml に「network.host:0.0.0.0」 を設定していなかった、
ことによるものののようでした。ただ、上記を設定したとたんに起動時に
[1]: max file descriptors [4096] for elasticsearch process is too low, increase to at least [65536]
[2]: max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]
のエラーが出始めたので、OS側の設定を色々変更することで対応できました。
ありがとうございました。

おそらく、OS側の設定をいろいろ、というのは以下のような内容かと思います。
後々、他の方が検索してこのスレッドをみたとき用に。

File Descriptors

https://www.elastic.co/guide/en/elasticsearch/reference/current/file-descriptors.html

On macOS, you must also pass the JVM option -XX:-MaxFDLimit to Elasticsearch in order for it to make use of the higher file descriptor limit.

Virtual Memory

https://www.elastic.co/guide/en/elasticsearch/reference/current/vm-max-map-count.html

On Linux, you can increase the limits by running the following command as root :
sysctl -w vm.max_map_count=262144

1 Like

フォロー頂きましてありがとうございます。

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.