Elasticsearch did not respond with license information

My ES yml file:

---------------------------------- Cluster -----------------------------------

Use a descriptive name for your cluster:

cluster.name: test-app-cluster

------------------------------------ Node ------------------------------------

Use a descriptive name for the node:

node.name: node-1

Add custom attributes to the node:

node.attr.rack: r1

----------------------------------- Paths ------------------------------------

Path to directory where to store the data (separate multiple locations by comma):

path.data: D:/Test-Datasets/test

Path to log files:

path.logs: D:/Test-Datasets/logs

----------------------------------- Memory -----------------------------------

Lock the memory on startup:

bootstrap.memory_lock: true

Make sure that the heap size is set to about half the memory available

on the system and that the owner of the process is allowed to use this

limit.

Elasticsearch performs poorly when the system is swapping the memory.

---------------------------------- Network -----------------------------------

Set the bind address to a specific IP (IPv4 or IPv6):

network.host: 12.345.67.89

Set a custom port for HTTP:

http.port: 9200

For more information, consult the network module documentation.

--------------------------------- Discovery ----------------------------------

Pass an initial list of hosts to perform discovery when this node is started:

The default list of hosts is ["127.0.0.1", "[::1]"]

discovery.seed_hosts: ["127.0.0.1"]

Bootstrap the cluster using an initial set of master-eligible nodes:

cluster.initial_master_nodes: ["node-1"]

For more information, consult the discovery and cluster formation module documentation.

---------------------------------- Gateway -----------------------------------

Block initial recovery after a full cluster restart until N nodes are started:

gateway.recover_after_nodes: 3

For more information, consult the gateway module documentation.

---------------------------------- Various -----------------------------------

Require explicit names when deleting indices:

action.destructive_requires_name: true

My Kibana yml file

server.port: 5601

Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.

The default is 'localhost', which usually means remote machines will not be able to connect.

To allow connections from remote users, set this parameter to a non-loopback address.

server.host: "10.206.36.50"

Enables you to specify a path to mount Kibana at if you are running behind a proxy.

Use the server.rewriteBasePath setting to tell Kibana if it should remove the basePath

from requests it receives, and to prevent a deprecation warning at startup.

This setting cannot end in a slash.

#server.basePath: ""

Specifies whether Kibana should rewrite requests that are prefixed with

server.basePath or require that they are rewritten by your reverse proxy.

This setting was effectively always false before Kibana 6.3 and will

default to true starting in Kibana 7.0.

#server.rewriteBasePath: false

The maximum payload size in bytes for incoming server requests.

#server.maxPayloadBytes: 1048576

The Kibana server's name. This is used for display purposes.

server.name: "test-kibana-host"

The URLs of the Elasticsearch instances to use for all your queries.

elasticsearch.hosts: ["http://12.345.67.89:9200"]

When this setting's value is true Kibana uses the hostname specified in the server.host

setting. When the value of this setting is false, Kibana uses the hostname of the host

that connects to this Kibana instance.

elasticsearch.preserveHost: true

Kibana uses an index in Elasticsearch to store saved searches, visualizations and

dashboards. Kibana creates a new index if the index doesn't already exist.

kibana.index: ".kibana"

The default application to load.

kibana.defaultAppId: "home"

I am able to access the ES node from another PC. But my Kibana refuses to start. It says Elasticsearch did not respond with license information. Then I tried a solution suggested in another thread.
curl -uelastic -XPOST 'http://localhost:9200/_xpack/license/start_basic'

but I got another error (503) saying:
error":{"root_cause":[{"type":"cluster_block_exception","reason":"blocked by: [SERVICE_UNAVAILABLE/1/state not recovered / initialized];"}],"type":"master_not_discovered_exception","reason":"ClusterBlockException[blocked by: [SERVICE_UNAVAILABLE/1/state not recovered / initialized];]","caused_by":{"type":"cluster_block_exception","reason":"blocked by: [SERVICE_UNAVAILABLE/1/state not recovered / initialized];"}},"status":503}

Help please!

please take the time to properly format your code snippets. This is super hard to read. You can use markdown in this forum. In your configuration you set:

This means you need a certain amount of nodes in order to recover and be up.

On top of that, it seems that Elasticsearch is bound to localhost, but it needs to listen on a network in order to be reachable by kibana, unless kibana is running no that same system.

elasticsearch.yml

cluster.name: test-app-cluster
node.name: node-1
node.attr.rack: r1

path.data: D:/Test-Datasets/test
path.logs: D:/Test-Datasets/logs

bootstrap.memory_lock: true

network.host: 12.345.67.89
http.port: 9200

discovery.seed_hosts: ["127.0.0.1"]
cluster.initial_master_nodes: ["node-1"]

gateway.recover_after_nodes: 3

action.destructive_requires_name: true
xpack.license.self_generated.type: basic

kibana.yml

server.port: 5601
server.host: "12.345.67.89"
server.name: "test-kibana-host"

elasticsearch.hosts: ["http://12.345.67.89:9200"]
elasticsearch.preserveHost: true

kibana.index: ".kibana"
kibana.defaultAppId: "home"

Results
ES node can be accessed on the network.
When I launch Kibana I am getting "Elasticsearch did not respond with license information" error

I tried to rectify it using solution from another thread, which is:
curl -uelastic -XPOST 'http://localhost:9200/_xpack/license/start_basic'

but I got an error 503 saying:
error":{"root_cause":[{"type":"cluster_block_exception","reason":"blocked by: [SERVICE_UNAVAILABLE/1/state not recovered / initialized];"}],"type":"master_not_discovered_exception","reason":"ClusterBlockException[blocked by: [SERVICE_UNAVAILABLE/1/state not recovered / initialized];]","caused_by":{"type":"cluster_block_exception","reason":"blocked by: [SERVICE_UNAVAILABLE/1/state not recovered / initialized];"}},"status":503}

Kibana is running on the same system. But I want to be able to access it from other systems on the network.

how many nodes are you running? can you remove the gateway option above if you only have a single node. Also, please provide full logs of elasticsearch starting up. thanks.

Hi, changed my config files to the following.

elasticsearch.yml

network.host: pc-name-a123
cluster.initial_master_nodes: node-1

kibana.yml
server.host: pc-name-a123
server.name: pc-name-a123
elasticsearch.hosts: ["http://pc-name-a123:9200"]

Basically I changed it to my PC name, so I can access it on LAN. Both Kibana and Elaticsearch can be accessed from any PC on the network.
Thanks!

1 Like