Elasticsearch Docker: flood stage disk watermark [95%] exceeded

I have a similar issue to the one posted here: https://stackoverflow.com/questions/50609417/elasticsearch-error-cluster-block-exception-forbidden-12-index-read-only-all

I'm running Elasticsearch and Kibana with docker-compose on a big cluster with lots of free space. Still I get the same warning: flood stage disk watermark [95%] exceeded

Is there a way to have these settings saved in the docker environment, so that I don't need to manually set it with curl each time? I already had these settings in the elasticsearch.yml file:

cluster.routing.allocation.disk.watermark.flood_stage: 15gb
cluster.routing.allocation.disk.watermark.low: 30gb
cluster.routing.allocation.disk.watermark.high: 20gb

But that didn't change anything.

Plus: My Kibana doesn't run like it should.
It tells me:

Another Kibana instance appears to be migrating the index. Waiting for that migration to complete.
I already tried other approaches I found online, but they didn't help much.

Any help is much appreciated.

Docker info output for reference:

 Containers: 6
  Running: 3
  Paused: 0
  Stopped: 3
 Images: 185
 Server Version: 19.03.12
 Storage Driver: overlay
  Backing Filesystem: extfs
  Supports d_type: true
 Logging Driver: json-file
 Cgroup Driver: cgroupfs
  Volume: local
  Network: bridge host ipvlan macvlan null overlay
  Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog
 Swarm: inactive
 Runtimes: runc nvidia
 Default Runtime: runc
 Init Binary: docker-init
 containerd version: 7ad184331fa3e55e52b890ea95e65ba581ae3429
 runc version: dc9208a3303feef5b3839f4323d9beb36df0a9dd
 init version: fec3683
 Security Options:
   Profile: default
 Kernel Version: 5.7.2-kd-cluster
 Operating System: Debian GNU/Linux 9 (stretch)
 OSType: linux
 Architecture: x86_64
 CPUs: 32
 Total Memory: 125.8GiB
 Name: dpl01
 Docker Root Dir: /data/docker
 Debug Mode: false
 Registry: https://index.docker.io/v1/
 Experimental: false
 Insecure Registries:
 Live Restore Enabled: false

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.