Elasticsearch does not take "index.max_result_window" in elasticsearch.yml


I want to set the max scroll size explicitly through the index.max_result_window setting for me to experiment with the different scroll sizes. I tried to add a line (such as "index.max_result_window: 10000") to the elasticsearch.yml file, but once I did that I could not restart the Elasticsearch service. As long as the line is in the elasticsearch.yml file, no matter it is with a value greater than, equal to, or less than (even lot less than) 10,000 (the default), the service won't restart. However, the service restarts successfully if I comment out or remove that line.

We are on Windows Server 2012 R2.

You can't put this value in elasticsearch.yml but on an index level using the update indices settings API: https://www.elastic.co/guide/en/elasticsearch/reference/current/indices-update-settings.html

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.