ElasticSearch dynamic_date_formats is not working if there is a mapping in the index (even if empty)

Using version : 1.4.2
OS: Ubuntu Linux 14.04
JVM: 1.7

Here is how you can reproduce the issue ... you will see that in the first
case the myfield properties is applied only ... and in the second
everything looks normal ...

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/43acfdf5-297c-43bd-91e5-45488216c369%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

I'm having this problem as well. I opened a bug for it
here: https://github.com/elasticsearch/elasticsearch/issues/9410

On Friday, January 16, 2015 at 4:29:06 AM UTC-8, Ipatios Asmanidis wrote:

Using version : 1.4.2
OS: Ubuntu Linux 14.04
JVM: 1.7

Here is how you can reproduce the issue ... you will see that in the first
case the myfield properties is applied only ... and in the second
everything looks normal ...

https://gist.github.com/ypasmk/df441c24a7de0f8ceb69

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3f3379be-6ecf-4181-b772-14ebae829880%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.