Elasticsearch exception [type=json_parse_exception, reason=Current token (VALUE_NUMBER_INT) not of boolean type

Hi all and sorry for my poor english.
I'm using docker docker.elastic.co/elasticsearch/elasticsearch:6.2.1 paired with spring data elasticsearch. The issue does not involve spring for sure.
When I try any kind of operation on docker elastic I got

lasticsearch exception [type=json_parse_exception, reason=Current token (VALUE_NUMBER_INT) not of boolean type

My entity is completely defined as text fields. Please helps

Could you provide a sample project, classes... which could help to understand what you are doing?

Also please use a more recent version. At least the latest 6.8 or better 7.9.2.

here my demo git

git clone https://gdilembo75@bitbucket.org/gdilembo75/demo.git

Try to run mvn clean install and test will fail

please help. It's an issue using Spring repository, any operations fails with that error

Please be patient in waiting for responses to your question and refrain from pinging multiple times asking for a response or opening multiple topics for the same question. This is a community forum, it may take time for someone to reply to your question. For more information please refer to the Community Code of Conduct specifically the section "Be patient". Also, please refrain from pinging folks directly, this is a forum and anyone that participates might be able to assist you.

If you are in need of a service with an SLA that covers response times for questions then you may want to consider talking to us about a subscription.

It's fine to answer on your own thread after 2 or 3 days (not including weekends) if you don't have an answer.

That said, I'm planning to look at this today if no urgency falls down.

I gave a first look.

When using springboot with elasticsearch, you need to be explicit with some transitive dependencies as SpringBoot declares a version 6.4...

Basically you can put this in your pom.xml:


See documentation here: https://docs.spring.io/spring-boot/docs/current/reference/html/howto.html#howto-customize-dependency-versions

I'd not start a new project with 6.8.12 but I'd prefer 7.9.2.

Could you update your project so you are using all the most recent versions?

1 Like

it works

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.