Elasticsearch Failed with signal

Good Morning, i'm newbie with elasticsearch.
I have installed zammad on the our server with elasticsearch.
ES service running but after about one hour has been killed with result 'signal'.
I have tried to change configuration file:
uncomment bootstrapmememorylock=true
uncomment maxlockedmemory=unlimited
Thank You for support
Best Regards

The error has been caused by swap memory of the server.
I have tried this solution Disable swapping | Elasticsearch Reference [5.5] | Elastic and now the service running.

Today elasticsearch has been crashed again.

Thank You

Hi @Joegio,

are you using a version 5.5 of Elasticsearch or are you on a more recent version?

The last "crash" looks like the host/container running Elasticsearch ran out of native memory (or some other resource), causing Elasticsearch to fail (we need threads). Perhaps you can assign more resources to the container?

Thank You for your answer...

I have installed elasticsearch 5.5 with zammad...

Yes, the problem has been caused by RAM...

Infact I have increased Ram and now the elasticsearch process running correctly..

Thank You