Elasticsearch field is analyzed despite template is configured to not analyze field

I posted this to stackoverflow but I'm hoping I will get better answers

My logstash template looks like this -

There are two fields, zone and username that I have set as not_analyzed yet
they continue to be analyzed and show as analyzed when I view the index
mapping. I have dropped the index multiple times in the hopes that it will
pick up the new template but the fields are always analyzed.

The index is dynamically created daily so I cannot set the mapping in the
index itself.

Is there something wrong with my template?

I tried this config also -
https://gist.github.com/gauravarora/359d71999ed811ae56c6 but doesn't work

I'm not sure what I am doing wrong, I have tried all the template configs I
have found via google but none of them seem to work.


You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/203539a7-ba9e-46e0-831d-07b90c468b28%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

I am also facing similar issue.
Can anyone help on this?