Elasticsearch-hadoop-2.4.2 and Elasticsearch version 5.0.0 support


(Kumar Deepankar) #1

Hi,

Please let meknow the compatible ES Hadoop version for elasticsearch version 5.0

Caused by: org.elasticsearch.hadoop.EsHadoopIllegalArgumentException: Unsupported/Unknown Elasticsearch version 5.0.0
at org.elasticsearch.hadoop.rest.InitializationUtils.discoverEsVersion(InitializationUtils.java:191)
... 16 more
2016-11-28 07:55:01,467 [main] WARN org.apache.pig.backend.hadoop.executionengine.mapReduceLayer.MapReduceLauncher - Ooops! Some job has failed! Specify -stop_on_failure if you want Pig to stop immediately on failure.
2016-11-28 07:55:01,468 [main] INFO org.apache.pig.backend.hadoop.executionengine.mapReduceLayer.MapReduceLauncher - job job_local_0001 has failed! Stop running all dependent jobs


(Christian Dahlqvist) #2

According to the support matrix you will need to upgrade to version 5.0 of the ES-Hadoop connector.


(Kumar Deepankar) #3

Thanks..Its working with 5.0


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.