Elasticsearch-hadoop disable dynamic mapping and set limit of total fields


#1

I am trying to use es-hadoop to move csv with 570 columns from hadoop to elasticsearch.
However, an error occurred:
Limit of total fields [1000] in index [shortterm] has been exceeded; Bailing out..

Three questions:

  1. I only have 570 fields, why is limit of the total fields [1000] reached?
  2. Is there any way to set the limit of total fields with one of the configuration keywords (https://www.elastic.co/guide/en/elasticsearch/hadoop/5.3/configuration.html)?
  3. Is it possible to disable dynamic mapping and only index a few fields with one of the configuration keywords?

(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.