Elasticsearch health status is yellow

monitoring

(Ghsos) #1

cluster like that

NODE 1:

cluster.name: mycluster
node.name: "node1"
node.master: true
node.data: true
discovery.zen.ping.multicast.enabled: false
discovery.zen.ping.unicast.hosts: ["192.168.0.71"]
transport.tcp.port: 9301
http.port: 9201

marvel.agent.exporters:
id1:
type: http
host: ["http://192.168.0.71:9302"]

NODE 2

cluster.name: mycluster
node.name: "node2"
node.master: true
node.data: true
discovery.zen.ping.multicast.enabled: false
discovery.zen.ping.unicast.hosts: ["192.168.0.71"]
transport.tcp.port: 9302
http.port: 9202
marvel.agent.exporters:
id1:
type: http
host: ["http://192.168.0.71:9301"]

but get the error,and the yellow alway is yellow :

[2016-05-18 10:27:12,833][ERROR][marvel.agent.exporter.http] exception when checking remote cluster
version on host [http://192.168.0.71:9301]
ElasticsearchException[unable to check remote cluster version: no available connection for host [htt
p://192.168.0.71:9301]]

the version is elasticsearch-2.2.1 (window 64)


(Mark Walkom) #2

Try with port 9300 instead.


(Chris Earle) #3

There's two things wrong here:

  1. You are setting up the HTTP exporter to send to the opposite node that is going to join the same cluster.

    • Why not just use the default, local exporter, which means you do not need to configure anything relative to Marvel?
  2. You are using the HTTP exporter with the Transport port(s). Use the appropriate HTTP (9201 and 9202).

    • A good rule of thumb is that, unless it's Java talking to ES, then it must be the HTTP port.

Hope that helps.


(Mark Walkom) #4

Ah yeah, derp to me there.... :stuck_out_tongue:


(system) #5