Elasticsearch https error

this error occured while configuring elasticsearch for https
Caused by: java.security.AccessControlException: access denied ("java.io.FilePermission" "/usr/share/elasticsearch/config/certs/elastic-certificates.p12" "read")
at java.security.AccessControlContext.checkPermission(AccessControlContext.java:472) ~[?:?]
at java.security.AccessController.checkPermission(AccessController.java:1044) ~[?:?]

also tried changing the location of file to /etc/elasticsearch/config/elastic-certificates.p12
same error access denied

The user as which elasticsearch runs doesn't have access to read the file, as clearly stated by the exception. What are the file permissions and the owner of this file ? Check with

ls -la /etc/elasticsearch/config/elastic-certificates.p12

The location of this file should be very specific and it can only be within a the configuration directory of elasticsearch. If you installed Elasticsearch with the deb or rpm package this is/etc/elasticsearch

thanks got it resolved

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.