Elasticsearch.in.sh: Bad substitution

Hello,

I cloned git repo like this:

git clone https://github.com/elasticsearch/elasticsearch.git

I tried to run elasticsearch in foreground but got:

$ cd elasticsearch/bin
$ ./elasticsearch -f
./elasticsearch: 3: ./elasticsearch.in.sh: Bad substitution

Did I do something wrong or is it a bug?

Best Regards,
Adam

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Please download the official package from download page and not source code.

If you want to build es yourself, run mvn install.

HTH

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 4 mai 2013 à 11:22, Adam Pawlaczek jezozwierzak@gmail.com a écrit :

Hello,

I cloned git repo like this:

git clone https://github.com/elasticsearch/elasticsearch.git

I tried to run elasticsearch in foreground but got:

$ cd elasticsearch/bin
$ ./elasticsearch -f
./elasticsearch: 3: ./elasticsearch.in.sh: Bad substitution

Did I do something wrong or is it a bug?

Best Regards,
Adam

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.