Elasticsearch installation issues

Hi Everyone,
I'm having some issues getting elasticsearch running on my windows laptop. I've tried using the guide Install Elasticsearch with .zip on Windows | Elasticsearch Guide [master] | Elastic but am getting an error message saying

"IllegalStateException: failed to obtain node locks, tried [path\elasticsearch-8.3.2-windows-x86_64\elasticsearch-8.3.2\data]; maybe these locations are not writable or multiple nodes were started on the same data path?"

Any idea how to fix it? I've tried running elasticsearch.bat without changing the .yml file like the guied said and it took over an hour on one of the steps which didnt feel right.

I appreciate any help I can get.

Kind regards,

Welcome to our community! :smiley:

First up, check that there are no other Elasticsearch processes running using task manager or something similar. Once that is done, try starting Elasticsearch again.
If you get the same error, stop all Elasticsearch processes again and then delete the elasticsearch-8.3.2-windows-x86_64\elasticsearch-8.3.2\data directory, and try starting Elasticsearch again.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.