Elasticsearch IP Filtering Not Working

Trying to white list IP's using XPACK security but not workign as expected
My config is as below

cluster.name: elasticsearch-acsrep
node.name: ES1
path.data: /home/ematoacs/data/
path.logs: /home/ematoacs/log/
network.host: 10.x.x.48
http.host: 10.x.x.48
http.port: 9200
#cluster.initial_master_nodes: ["ES1"]
#http.cors.enabled: true
#http.cors.allow-origin: "*"
xpack.security.enabled: true
discovery.type: single-node
#xpack.security.http.ssl.enabled: true

xpack.security.http.filter.enabled: true
xpack.security.http.filter.allow: 10.x.x.181
xpack.security.http.filter.deny: 10.x.x.55

xpack.security.transport.filter.enabled: true
xpack.security.transport.filter.allow: 10.x.x.181
xpack.security.transport.filter.deny: _all

still m able to access the ES API's from any host in my network

What is the license of the cluster? IP filtering is a feature for Gold license and up. You can also try it out by activating trial license.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.