Elasticsearch Java version requirement

Hi

I am using Elasticsearch 1.4.1 and have read from the following links that*
Java 1.7.0.55* and above are the recommended version to run Elasticsearch
with.
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/setup.html


From the last blog post it has been pointed out that the bug that causes
index corruption is between 1.7.0.25 to 1.7.0.55. I would like to know
whether Java 1.7.0.21 is safe to run Elasticsearch with because I have
another software/jar that requires me to run that particular version of
Java.

Thanks

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/eccfe9c6-0fdb-413b-9298-8aa2ff18c5d9%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

The recommendations for ElasticSearch Java versions are pretty rigid. There
are bugs in various JREs that affect Lucene and ElasticSearch. 1.7.0_60
seems to work correctly, at least for ES 1.3.4. (1.7.0_67 does not - it
doesn't deal with empty data fields the way the ES docs say it should.) I
recommend 1.7.0_60 as a good stable version, and at least at one point,
that specific version was publicly mentioned for ES installs... I don't
know anything about 1.8...

The first link you provide says it all: using a non-recommended JVM prior
to 1.7.0_55 can lead to data corruption and loss. Don't do it.

--
Les

On Sat, Dec 13, 2014 at 5:28 PM, Wei Yuan Cho choweiyuan@gmail.com wrote:

Hi

I am using Elasticsearch 1.4.1 and have read from the following links that*
Java 1.7.0.55* and above are the recommended version to run Elasticsearch
with.

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/setup.html

http://www.elasticsearch.org/blog/java-1-7u55-safe-use-elasticsearch-lucene/

http://www.elasticsearch.org/blog/elasticsearch-1-2-0-released/

From the last blog post it has been pointed out that the bug that causes
index corruption is between 1.7.0.25 to 1.7.0.55. I would like to know
whether Java 1.7.0.21 is safe to run Elasticsearch with because I have
another software/jar that requires me to run that particular version of
Java.

Thanks

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/eccfe9c6-0fdb-413b-9298-8aa2ff18c5d9%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/eccfe9c6-0fdb-413b-9298-8aa2ff18c5d9%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAOppbCUywLZ-EpwQnsS2x2ziwYmvQFLY58wT-%3DUnG890gftmVw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.