Elasticsearch & Kibana JVM Management


(Rodrigo Porto) #1

Hi everyone,

I have a doubt about JVM usage with Elasticsarch & Kibana. For example, I have an Elasticsearch 1.7.5 and Kibana 3. In a normal conditions Elasticsearch has 30% heap usage, when I use Kibana and I try to obtain information, jvm heap usage increase to 60% or 70%.

When I stop using Kibana, this JVM heap usage remains, so, how long time Elasticsearch
needs to free this JVM? Is there any way to accelerate it?

Another question, it would be advisable to use Elasticsearch 2.x or 5.x to improve it?

Thanks in advance :slight_smile:,

Regards


(David Pilato) #2

Is there any problem that the JVM usage is still at 60% or 70%?
Unless you are seeing errors or warnings about the garbage collector, I'd not really care about this.


(Rodrigo Porto) #3

Hi David,

First of all, thanks for your answer. Regarding to my doubt,the problem is that if I come back to use Kibana 3 (for example, another Dashboards or the same), JVM usage increases until 90% or 100%. So , the errors appears like (example of Internet):

[2015-07-01 06:43:19,525][INFO ][monitor.jvm] [my_node] [gc][old][205450][116]duration [5.7s], collections [1]/[6.3s], total [5.7s]/[1m],memory [22.3gb]->[4.9gb]/[30.9gb]

If I stop using Kibana, why the JVM heap usage remains?

Thanks in advance,

Regards


(David Pilato) #4

You are running low on memory for sure. So answering now to this question:

it would be advisable to use Elasticsearch 2.x or 5.x to improve it?

Yes. Definitely. Before 2.x you were using I guess field data a lot. It has been "replaced" by doc_values.
Also, lot of improvements since Kibana3 when it comes to querying ES.

I'd go to that way.


(Rodrigo Porto) #5

Thank you very much for your advise :slight_smile:.

Regards


(Miguel) #6

Hello! I 'm using 2.4 version of Elasticsearch and I'm having the same issues. Even if I close all the Indexes the JVM doesn't decrease. Is there any place where I can find docs about the internal processes of Elasticsearch? Is there any way to reduce of memory usage?
I've tried to clean, shrink and forcemerge to: get the cache cleaned and reduce the shards/indexes but nothing worked for me.
Thank you in advance,

Miguel


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.