ElasticSearch : No ElasticSearch node is available Exception


(Bjørn Bråthen) #1

I'm trying to deploy Elasticsearch to Amazon web services EC2. I have
got it up and working for normal http REST requests from my own computer
using curl, but when I try to use the Java Client API
(w/Play2-elasticsearch) on the same computer it throws me this error:

[error] application - ElasticSearch : No ElasticSearch node is available.
Please check that your configuration is correct, that you ES server is up
and reachable from the network. Index has not been created and prepared.
org.elasticsearch.client.transport.NoNodeAvailableException: No node
available
at org.elasticsearch.client.transport.TransportClientNodesService.execute(
TransportClientNodesService.java:205) ~[elasticsearch-0.90.3.jar:na]
at org.elasticsearch.client.transport.support.
InternalTransportIndicesAdminClient.execute(
InternalTransportIndicesAdminClient.java:85) ~[elasticsearch-0.90.3.jar:na]
at org.elasticsearch.client.support.AbstractIndicesAdminClient.exists(
AbstractIndicesAdminClient.java:147) ~[elasticsearch-0.90.3.jar:na]
at org.elasticsearch.action.admin.indices.exists.indices.
IndicesExistsRequestBuilder.doExecute(IndicesExistsRequestBuilder.java:43)
~[elasticsearch-0.90.3.jar:na]
at org.elasticsearch.action.ActionRequestBuilder.execute(
ActionRequestBuilder.java:85) ~[elasticsearch-0.90.3.jar:na]
at org.elasticsearch.action.ActionRequestBuilder.execute(
ActionRequestBuilder.java:59) ~[elasticsearch-0.90.3.jar:na]
[info] application - Application has started
[error] application -

I've opened both inbound 9300 and 9200 ports on my EC2, and this is my *
elasticsearch.yml*:

cluster.name: portal
node.name: "Skald"
node.master: true
node.data: true
index.number_of_shards: 1

index.number_of_replicas: 0
transport.tcp.port: 9300
http.port: 9200
discovery.zen.ping.multicast.enabled: false
cloud.aws.region: us-west-2

cloud:
aws:
access_key:my_access_key
secret_key:My_secret
discovery:
type: ec2

I additionally get this info-snippet in the elasticsearch console:
[2013-08-18 19:24:11,710][INFO ][discovery.ec2 ] [Skald]
Exception while retrieving instance list from AWS API: Unable to load AWS
credentials from any provider in the chain

In the play2-elasticsearch module I've set:
elasticsearch.local=false
elasticsearch.client="ec2-63-32-3-23.us-west-2.compute.amazonaws.com:9300"
elasticsearch.cluster.name="portal"
elasticsearch.index.name="index1,index2"
elasticsearch.index.clazzs="indexing.*"
elasticsearch.index.show_request=false

Anybody got an idea, why this isn't working?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Bjørn Bråthen) #2

Sorry, i'm using: elasticsearch-cloud-aws plugin 1.14.0, elasticsearch
0.90.3 and play2-elasticsearch 0.7-snapshot

On Sunday, August 18, 2013 9:52:31 PM UTC+2, Bjørn Bråthen wrote:

I'm trying to deploy Elasticsearch to Amazon web services EC2. I have
got it up and working for normal http REST requests from my own computer
using curl, but when I try to use the Java Client API
(w/Play2-elasticsearch) on the same computer it throws me this error:

[error] application - ElasticSearch : No ElasticSearch node is available.
Please check that your configuration is correct, that you ES server is up
and reachable from the network. Index has not been created and prepared.
org.elasticsearch.client.transport.NoNodeAvailableException: No node
available
at org.elasticsearch.client.transport.TransportClientNodesService.execute
(TransportClientNodesService.java:205) ~[elasticsearch-0.90.3.jar:na]
at org.elasticsearch.client.transport.support.
InternalTransportIndicesAdminClient.execute(
InternalTransportIndicesAdminClient.java:85) ~[elasticsearch-0.90.3.jar:na
]
at org.elasticsearch.client.support.AbstractIndicesAdminClient.exists(
AbstractIndicesAdminClient.java:147) ~[elasticsearch-0.90.3.jar:na]
at org.elasticsearch.action.admin.indices.exists.indices.
IndicesExistsRequestBuilder.doExecute(IndicesExistsRequestBuilder.java:43)
~[elasticsearch-0.90.3.jar:na]
at org.elasticsearch.action.ActionRequestBuilder.execute(
ActionRequestBuilder.java:85) ~[elasticsearch-0.90.3.jar:na]
at org.elasticsearch.action.ActionRequestBuilder.execute(
ActionRequestBuilder.java:59) ~[elasticsearch-0.90.3.jar:na]
[info] application - Application has started
[error] application -

I've opened both inbound 9300 and 9200 ports on my EC2, and this is
my elasticsearch.yml:

cluster.name: portal
node.name: "Skald"
node.master: true
node.data: true
index.number_of_shards: 1

index.number_of_replicas: 0
transport.tcp.port: 9300
http.port: 9200
discovery.zen.ping.multicast.enabled: false
cloud.aws.region: us-west-2

cloud:
aws:
access_key:my_access_key
secret_key:My_secret
discovery:
type: ec2

I additionally get this info-snippet in the elasticsearch console:
[2013-08-18 19:24:11,710][INFO ][discovery.ec2 ] [Skald]
Exception while retrieving instance list from AWS API: Unable to load AWS
credentials from any provider in the chain

In the play2-elasticsearch module I've set:
elasticsearch.local=false
elasticsearch.client="ec2-63-32-3-23.us-west-2.compute.amazonaws.com:9300"
elasticsearch.cluster.name="portal"
elasticsearch.index.name="index1,index2"
elasticsearch.index.clazzs="indexing.*"
elasticsearch.index.show_request=false

Anybody got an idea, why this isn't working?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Bjørn Bråthen) #3

I did a telnet against my node at port 9300, and a connection was
established. Is this maybe a play2-elasticsearch 0.7-snapshot issue?

On Sunday, August 18, 2013 9:52:31 PM UTC+2, Bjørn Bråthen wrote:

I'm trying to deploy Elasticsearch to Amazon web services EC2. I have
got it up and working for normal http REST requests from my own computer
using curl, but when I try to use the Java Client API
(w/Play2-elasticsearch) on the same computer it throws me this error:

[error] application - ElasticSearch : No ElasticSearch node is available.
Please check that your configuration is correct, that you ES server is up
and reachable from the network. Index has not been created and prepared.
org.elasticsearch.client.transport.NoNodeAvailableException: No node
available
at org.elasticsearch.client.transport.TransportClientNodesService.execute
(TransportClientNodesService.java:205) ~[elasticsearch-0.90.3.jar:na]
at org.elasticsearch.client.transport.support.
InternalTransportIndicesAdminClient.execute(
InternalTransportIndicesAdminClient.java:85) ~[elasticsearch-0.90.3.jar:na
]
at org.elasticsearch.client.support.AbstractIndicesAdminClient.exists(
AbstractIndicesAdminClient.java:147) ~[elasticsearch-0.90.3.jar:na]
at org.elasticsearch.action.admin.indices.exists.indices.
IndicesExistsRequestBuilder.doExecute(IndicesExistsRequestBuilder.java:43)
~[elasticsearch-0.90.3.jar:na]
at org.elasticsearch.action.ActionRequestBuilder.execute(
ActionRequestBuilder.java:85) ~[elasticsearch-0.90.3.jar:na]
at org.elasticsearch.action.ActionRequestBuilder.execute(
ActionRequestBuilder.java:59) ~[elasticsearch-0.90.3.jar:na]
[info] application - Application has started
[error] application -

I've opened both inbound 9300 and 9200 ports on my EC2, and this is
my elasticsearch.yml:

cluster.name: portal
node.name: "Skald"
node.master: true
node.data: true
index.number_of_shards: 1

index.number_of_replicas: 0
transport.tcp.port: 9300
http.port: 9200
discovery.zen.ping.multicast.enabled: false
cloud.aws.region: us-west-2

cloud:
aws:
access_key:my_access_key
secret_key:My_secret
discovery:
type: ec2

I additionally get this info-snippet in the elasticsearch console:
[2013-08-18 19:24:11,710][INFO ][discovery.ec2 ] [Skald]
Exception while retrieving instance list from AWS API: Unable to load AWS
credentials from any provider in the chain

In the play2-elasticsearch module I've set:
elasticsearch.local=false
elasticsearch.client="ec2-63-32-3-23.us-west-2.compute.amazonaws.com:9300"
elasticsearch.cluster.name="portal"
elasticsearch.index.name="index1,index2"
elasticsearch.index.clazzs="indexing.*"
elasticsearch.index.show_request=false

Anybody got an idea, why this isn't working?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Bjørn Bråthen) #4

It was a Play2-elasticsearch issue, client.transport.sniff was set to true
on default, turned client.transport.sniff to false and it worked.

On Sunday, August 18, 2013 9:52:31 PM UTC+2, Bjørn Bråthen wrote:

I'm trying to deploy Elasticsearch to Amazon web services EC2. I have
got it up and working for normal http REST requests from my own computer
using curl, but when I try to use the Java Client API
(w/Play2-elasticsearch) on the same computer it throws me this error:

[error] application - ElasticSearch : No ElasticSearch node is available.
Please check that your configuration is correct, that you ES server is up
and reachable from the network. Index has not been created and prepared.
org.elasticsearch.client.transport.NoNodeAvailableException: No node
available
at org.elasticsearch.client.transport.TransportClientNodesService.execute
(TransportClientNodesService.java:205) ~[elasticsearch-0.90.3.jar:na]
at org.elasticsearch.client.transport.support.
InternalTransportIndicesAdminClient.execute(
InternalTransportIndicesAdminClient.java:85) ~[elasticsearch-0.90.3.jar:na
]
at org.elasticsearch.client.support.AbstractIndicesAdminClient.exists(
AbstractIndicesAdminClient.java:147) ~[elasticsearch-0.90.3.jar:na]
at org.elasticsearch.action.admin.indices.exists.indices.
IndicesExistsRequestBuilder.doExecute(IndicesExistsRequestBuilder.java:43)
~[elasticsearch-0.90.3.jar:na]
at org.elasticsearch.action.ActionRequestBuilder.execute(
ActionRequestBuilder.java:85) ~[elasticsearch-0.90.3.jar:na]
at org.elasticsearch.action.ActionRequestBuilder.execute(
ActionRequestBuilder.java:59) ~[elasticsearch-0.90.3.jar:na]
[info] application - Application has started
[error] application -

I've opened both inbound 9300 and 9200 ports on my EC2, and this is
my elasticsearch.yml:

cluster.name: portal
node.name: "Skald"
node.master: true
node.data: true
index.number_of_shards: 1

index.number_of_replicas: 0
transport.tcp.port: 9300
http.port: 9200
discovery.zen.ping.multicast.enabled: false
cloud.aws.region: us-west-2

cloud:
aws:
access_key:my_access_key
secret_key:My_secret
discovery:
type: ec2

I additionally get this info-snippet in the elasticsearch console:
[2013-08-18 19:24:11,710][INFO ][discovery.ec2 ] [Skald]
Exception while retrieving instance list from AWS API: Unable to load AWS
credentials from any provider in the chain

In the play2-elasticsearch module I've set:
elasticsearch.local=false
elasticsearch.client="ec2-63-32-3-23.us-west-2.compute.amazonaws.com:9300"
elasticsearch.cluster.name="portal"
elasticsearch.index.name="index1,index2"
elasticsearch.index.clazzs="indexing.*"
elasticsearch.index.show_request=false

Anybody got an idea, why this isn't working?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Ali Emami) #5

hey Bjorn, how did you turn client.transport.sniff off? from configuration
or from the code?? thanks

On Tuesday, August 20, 2013 10:04:44 AM UTC-4, Bjørn Bråthen wrote:

It was a Play2-elasticsearch issue, client.transport.sniff was set to true
on default, turned client.transport.sniff to false and it worked.

On Sunday, August 18, 2013 9:52:31 PM UTC+2, Bjørn Bråthen wrote:

I'm trying to deploy Elasticsearch to Amazon web services EC2. I
have got it up and working for normal http REST requests from my own
computer using curl, but when I try to use the Java Client API
(w/Play2-elasticsearch) on the same computer it throws me this error:

[error] application - ElasticSearch : No ElasticSearch node is available.
Please check that your configuration is correct, that you ES server isup
and reachable from the network. Index has not been created and prepared.
org.elasticsearch.client.transport.NoNodeAvailableException: No node
available
at org.elasticsearch.client.transport.TransportClientNodesService.
execute(TransportClientNodesService.java:205) ~[elasticsearch-0.90.3.jar:
na]
at org.elasticsearch.client.transport.support.
InternalTransportIndicesAdminClient.execute(
InternalTransportIndicesAdminClient.java:85) ~[elasticsearch-0.90.3.jar:
na]
at org.elasticsearch.client.support.AbstractIndicesAdminClient.exists(
AbstractIndicesAdminClient.java:147) ~[elasticsearch-0.90.3.jar:na]
at org.elasticsearch.action.admin.indices.exists.indices.
IndicesExistsRequestBuilder.doExecute(IndicesExistsRequestBuilder.java:43
) ~[elasticsearch-0.90.3.jar:na]
at org.elasticsearch.action.ActionRequestBuilder.execute(
ActionRequestBuilder.java:85) ~[elasticsearch-0.90.3.jar:na]
at org.elasticsearch.action.ActionRequestBuilder.execute(
ActionRequestBuilder.java:59) ~[elasticsearch-0.90.3.jar:na]
[info] application - Application has started
[error] application -

I've opened both inbound 9300 and 9200 ports on my EC2, and this is
my elasticsearch.yml:

cluster.name: portal
node.name: "Skald"
node.master: true
node.data: true
index.number_of_shards: 1

index.number_of_replicas: 0
transport.tcp.port: 9300
http.port: 9200
discovery.zen.ping.multicast.enabled: false
cloud.aws.region: us-west-2

cloud:
aws:
access_key:my_access_key
secret_key:My_secret
discovery:
type: ec2

I additionally get this info-snippet in the elasticsearch console:
[2013-08-18 19:24:11,710][INFO ][discovery.ec2 ] [Skald]
Exception while retrieving instance list from AWS API: Unable to load AWS
credentials from any provider in the chain

In the play2-elasticsearch module I've set:
elasticsearch.local=false
elasticsearch.client="ec2-63-32-3-23.us-west-2.compute.amazonaws.com:9300
"
elasticsearch.cluster.name="portal"
elasticsearch.index.name="index1,index2"
elasticsearch.index.clazzs="indexing.*"
elasticsearch.index.show_request=false

Anybody got an idea, why this isn't working?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Bjørn Bråthen) #6

I created a sniff option for the module and pushed it to git. In the
application.conf, do:

elasticsearch.sniff=false

to turn sniffing for nodes off.

On Friday, October 4, 2013 8:27:57 AM UTC+2, Ali Emami wrote:

hey Bjorn, how did you turn client.transport.sniff off? from configuration
or from the code?? thanks

On Tuesday, August 20, 2013 10:04:44 AM UTC-4, Bjørn Bråthen wrote:

It was a Play2-elasticsearch issue, client.transport.sniff was set to
true on default, turned client.transport.sniff to false and it worked.

On Sunday, August 18, 2013 9:52:31 PM UTC+2, Bjørn Bråthen wrote:

I'm trying to deploy Elasticsearch to Amazon web services EC2. I
have got it up and working for normal http REST requests from my own
computer using curl, but when I try to use the Java Client API
(w/Play2-elasticsearch) on the same computer it throws me this error:

[error] application - ElasticSearch : No ElasticSearch node is available
. Please check that your configuration is correct, that you ES server isup
and reachable from the network. Index has not been created and prepared.
org.elasticsearch.client.transport.NoNodeAvailableException: No node
available
at org.elasticsearch.client.transport.TransportClientNodesService.
execute(TransportClientNodesService.java:205) ~[elasticsearch-0.90.3.jar
:na]
at org.elasticsearch.client.transport.support.
InternalTransportIndicesAdminClient.execute(
InternalTransportIndicesAdminClient.java:85) ~[elasticsearch-0.90.3.jar:
na]
at org.elasticsearch.client.support.AbstractIndicesAdminClient.exists(
AbstractIndicesAdminClient.java:147) ~[elasticsearch-0.90.3.jar:na]
at org.elasticsearch.action.admin.indices.exists.indices.
IndicesExistsRequestBuilder.doExecute(IndicesExistsRequestBuilder.java:
43) ~[elasticsearch-0.90.3.jar:na]
at org.elasticsearch.action.ActionRequestBuilder.execute(
ActionRequestBuilder.java:85) ~[elasticsearch-0.90.3.jar:na]
at org.elasticsearch.action.ActionRequestBuilder.execute(
ActionRequestBuilder.java:59) ~[elasticsearch-0.90.3.jar:na]
[info] application - Application has started
[error] application -

I've opened both inbound 9300 and 9200 ports on my EC2, and this is
my elasticsearch.yml:

cluster.name: portal
node.name: "Skald"
node.master: true
node.data: true
index.number_of_shards: 1

index.number_of_replicas: 0
transport.tcp.port: 9300
http.port: 9200
discovery.zen.ping.multicast.enabled: false
cloud.aws.region: us-west-2

cloud:
aws:
access_key:my_access_key
secret_key:My_secret
discovery:
type: ec2

I additionally get this info-snippet in the elasticsearch console:
[2013-08-18 19:24:11,710][INFO ][discovery.ec2 ] [Skald]
Exception while retrieving instance list from AWS API: Unable to load AWS
credentials from any provider in the chain

In the play2-elasticsearch module I've set:
elasticsearch.local=false
elasticsearch.client="
ec2-63-32-3-23.us-west-2.compute.amazonaws.com:9300"
elasticsearch.cluster.name="portal"
elasticsearch.index.name="index1,index2"
elasticsearch.index.clazzs="indexing.*"
elasticsearch.index.show_request=false

Anybody got an idea, why this isn't working?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Bjørn Bråthen) #7

And, i'm using Play2-elasticsearch 0.7-SNAPSHOT by the way.

On Friday, October 4, 2013 8:27:57 AM UTC+2, Ali Emami wrote:

hey Bjorn, how did you turn client.transport.sniff off? from configuration
or from the code?? thanks

On Tuesday, August 20, 2013 10:04:44 AM UTC-4, Bjørn Bråthen wrote:

It was a Play2-elasticsearch issue, client.transport.sniff was set to
true on default, turned client.transport.sniff to false and it worked.

On Sunday, August 18, 2013 9:52:31 PM UTC+2, Bjørn Bråthen wrote:

I'm trying to deploy Elasticsearch to Amazon web services EC2. I
have got it up and working for normal http REST requests from my own
computer using curl, but when I try to use the Java Client API
(w/Play2-elasticsearch) on the same computer it throws me this error:

[error] application - ElasticSearch : No ElasticSearch node is available
. Please check that your configuration is correct, that you ES server isup
and reachable from the network. Index has not been created and prepared.
org.elasticsearch.client.transport.NoNodeAvailableException: No node
available
at org.elasticsearch.client.transport.TransportClientNodesService.
execute(TransportClientNodesService.java:205) ~[elasticsearch-0.90.3.jar
:na]
at org.elasticsearch.client.transport.support.
InternalTransportIndicesAdminClient.execute(
InternalTransportIndicesAdminClient.java:85) ~[elasticsearch-0.90.3.jar:
na]
at org.elasticsearch.client.support.AbstractIndicesAdminClient.exists(
AbstractIndicesAdminClient.java:147) ~[elasticsearch-0.90.3.jar:na]
at org.elasticsearch.action.admin.indices.exists.indices.
IndicesExistsRequestBuilder.doExecute(IndicesExistsRequestBuilder.java:
43) ~[elasticsearch-0.90.3.jar:na]
at org.elasticsearch.action.ActionRequestBuilder.execute(
ActionRequestBuilder.java:85) ~[elasticsearch-0.90.3.jar:na]
at org.elasticsearch.action.ActionRequestBuilder.execute(
ActionRequestBuilder.java:59) ~[elasticsearch-0.90.3.jar:na]
[info] application - Application has started
[error] application -

I've opened both inbound 9300 and 9200 ports on my EC2, and this is
my elasticsearch.yml:

cluster.name: portal
node.name: "Skald"
node.master: true
node.data: true
index.number_of_shards: 1

index.number_of_replicas: 0
transport.tcp.port: 9300
http.port: 9200
discovery.zen.ping.multicast.enabled: false
cloud.aws.region: us-west-2

cloud:
aws:
access_key:my_access_key
secret_key:My_secret
discovery:
type: ec2

I additionally get this info-snippet in the elasticsearch console:
[2013-08-18 19:24:11,710][INFO ][discovery.ec2 ] [Skald]
Exception while retrieving instance list from AWS API: Unable to load AWS
credentials from any provider in the chain

In the play2-elasticsearch module I've set:
elasticsearch.local=false
elasticsearch.client="
ec2-63-32-3-23.us-west-2.compute.amazonaws.com:9300"
elasticsearch.cluster.name="portal"
elasticsearch.index.name="index1,index2"
elasticsearch.index.clazzs="indexing.*"
elasticsearch.index.show_request=false

Anybody got an idea, why this isn't working?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Igor Motov) #8

Was the spaces after ":" removed as a result of your key obfuscation or
they are indeed missing in your real config?

            access_key:**my_access_key**
            secret_key:**My_secret**

Because if they are missing, it would explain the error message that you
are getting:

[2013-08-18 19:24:11,710][INFO ][discovery.ec2 ] [Skald]
Exception while retrieving instance list from AWS API: Unable to load AWS
credentials from any provider in the chain

On Friday, October 4, 2013 5:18:32 AM UTC-4, Bjørn Bråthen wrote:

And, i'm using Play2-elasticsearch 0.7-SNAPSHOT by the way.

On Friday, October 4, 2013 8:27:57 AM UTC+2, Ali Emami wrote:

hey Bjorn, how did you turn client.transport.sniff off? from
configuration or from the code?? thanks

On Tuesday, August 20, 2013 10:04:44 AM UTC-4, Bjørn Bråthen wrote:

It was a Play2-elasticsearch issue, client.transport.sniff was set to
true on default, turned client.transport.sniff to false and it worked.

On Sunday, August 18, 2013 9:52:31 PM UTC+2, Bjørn Bråthen wrote:

I'm trying to deploy Elasticsearch to Amazon web services EC2. I
have got it up and working for normal http REST requests from my own
computer using curl, but when I try to use the Java Client API
(w/Play2-elasticsearch) on the same computer it throws me this error:

[error] application - ElasticSearch : No ElasticSearch node isavailable
. Please check that your configuration is correct, that you ES server
is up and reachable from the network. Index has not been created andprepared
.
org.elasticsearch.client.transport.NoNodeAvailableException: No node
available
at org.elasticsearch.client.transport.TransportClientNodesService.
execute(TransportClientNodesService.java:205) ~[elasticsearch-0.90.
3.jar:na]
at org.elasticsearch.client.transport.support.
InternalTransportIndicesAdminClient.execute(
InternalTransportIndicesAdminClient.java:85) ~[elasticsearch-0.90.3.jar
:na]
at org.elasticsearch.client.support.AbstractIndicesAdminClient.exists(
AbstractIndicesAdminClient.java:147) ~[elasticsearch-0.90.3.jar:na]
at org.elasticsearch.action.admin.indices.exists.indices.
IndicesExistsRequestBuilder.doExecute(IndicesExistsRequestBuilder.java:
43) ~[elasticsearch-0.90.3.jar:na]
at org.elasticsearch.action.ActionRequestBuilder.execute(
ActionRequestBuilder.java:85) ~[elasticsearch-0.90.3.jar:na]
at org.elasticsearch.action.ActionRequestBuilder.execute(
ActionRequestBuilder.java:59) ~[elasticsearch-0.90.3.jar:na]
[info] application - Application has started
[error] application -

I've opened both inbound 9300 and 9200 ports on my EC2, and this
is my elasticsearch.yml:

cluster.name: portal
node.name: "Skald"
node.master: true
node.data: true
index.number_of_shards: 1

index.number_of_replicas: 0
transport.tcp.port: 9300
http.port: 9200
discovery.zen.ping.multicast.enabled: false
cloud.aws.region: us-west-2

cloud:
aws:
access_key:my_access_key
secret_key:My_secret
discovery:
type: ec2

I additionally get this info-snippet in the elasticsearch console:
[2013-08-18 19:24:11,710][INFO ][discovery.ec2 ] [Skald]
Exception while retrieving instance list from AWS API: Unable to load AWS
credentials from any provider in the chain

In the play2-elasticsearch module I've set:
elasticsearch.local=false
elasticsearch.client="
ec2-63-32-3-23.us-west-2.compute.amazonaws.com:9300"
elasticsearch.cluster.name="portal"
elasticsearch.index.name="index1,index2"
elasticsearch.index.clazzs="indexing.*"
elasticsearch.index.show_request=false

Anybody got an idea, why this isn't working?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Mark Betz) #9

Just wanted to say thanks for posting this, Igor. Solved a problem for me
this afternoon, and it would have taken a long time to stumble on this by
myself :).

On Friday, October 4, 2013 3:33:36 PM UTC-4, Igor Motov wrote:

Was the spaces after ":" removed as a result of your key obfuscation or
they are indeed missing in your real config?

            access_key:**my_access_key**
            secret_key:**My_secret**

Because if they are missing, it would explain the error message that you
are getting:

[2013-08-18 19:24:11,710][INFO ][discovery.ec2 ] [Skald]
Exception while retrieving instance list from AWS API: Unable to load AWS
credentials from any provider in the chain

On Friday, October 4, 2013 5:18:32 AM UTC-4, Bjørn Bråthen wrote:

And, i'm using Play2-elasticsearch 0.7-SNAPSHOT by the way.

On Friday, October 4, 2013 8:27:57 AM UTC+2, Ali Emami wrote:

hey Bjorn, how did you turn client.transport.sniff off? from
configuration or from the code?? thanks

On Tuesday, August 20, 2013 10:04:44 AM UTC-4, Bjørn Bråthen wrote:

It was a Play2-elasticsearch issue, client.transport.sniff was set to
true on default, turned client.transport.sniff to false and it worked.

On Sunday, August 18, 2013 9:52:31 PM UTC+2, Bjørn Bråthen wrote:

I'm trying to deploy Elasticsearch to Amazon web services EC2. I
have got it up and working for normal http REST requests from my own
computer using curl, but when I try to use the Java Client API
(w/Play2-elasticsearch) on the same computer it throws me this error:

[error] application - ElasticSearch : No ElasticSearch node isavailable
. Please check that your configuration is correct, that you ES server
is up and reachable from the network. Index has not been created andprepared
.
org.elasticsearch.client.transport.NoNodeAvailableException: No node
available
at org.elasticsearch.client.transport.TransportClientNodesService.
execute(TransportClientNodesService.java:205) ~[elasticsearch-0.90.
3.jar:na]
at org.elasticsearch.client.transport.support.
InternalTransportIndicesAdminClient.execute(
InternalTransportIndicesAdminClient.java:85) ~[elasticsearch-0.90.
3.jar:na]
at org.elasticsearch.client.support.AbstractIndicesAdminClient.exists
(AbstractIndicesAdminClient.java:147) ~[elasticsearch-0.90.3.jar:na]
at org.elasticsearch.action.admin.indices.exists.indices.
IndicesExistsRequestBuilder.doExecute(IndicesExistsRequestBuilder.java
:43) ~[elasticsearch-0.90.3.jar:na]
at org.elasticsearch.action.ActionRequestBuilder.execute(
ActionRequestBuilder.java:85) ~[elasticsearch-0.90.3.jar:na]
at org.elasticsearch.action.ActionRequestBuilder.execute(
ActionRequestBuilder.java:59) ~[elasticsearch-0.90.3.jar:na]
[info] application - Application has started
[error] application -

I've opened both inbound 9300 and 9200 ports on my EC2, and this
is my elasticsearch.yml:

cluster.name: portal
node.name: "Skald"
node.master: true
node.data: true
index.number_of_shards: 1

index.number_of_replicas: 0
transport.tcp.port: 9300
http.port: 9200
discovery.zen.ping.multicast.enabled: false
cloud.aws.region: us-west-2

cloud:
aws:
access_key:my_access_key
secret_key:My_secret
discovery:
type: ec2

I additionally get this info-snippet in the elasticsearch console:
[2013-08-18 19:24:11,710][INFO ][discovery.ec2 ] [Skald]
Exception while retrieving instance list from AWS API: Unable to load AWS
credentials from any provider in the chain

In the play2-elasticsearch module I've set:
elasticsearch.local=false
elasticsearch.client="
ec2-63-32-3-23.us-west-2.compute.amazonaws.com:9300"
elasticsearch.cluster.name="portal"
elasticsearch.index.name="index1,index2"
elasticsearch.index.clazzs="indexing.*"
elasticsearch.index.show_request=false

Anybody got an idea, why this isn't working?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/13c718b5-7922-4f97-bfa1-c2ff299179e8%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #10