ElasticSearch not seen in JPS


(Greg Bui) #1

Hello,

I encounter a weird problem, jps is not returning elasticsearch whereas it
is running and (seems) working fine. I remember that was the case before.
jstat is not working as well...

jps

243157 jruby-complete-1.7.11.jar
50184 Jps

ps aux | grep elasti

494 48931 54.3 13.0 383893516 4303840 ? Sl 17:29 3:07
/usr/java/default/bin/java -Xms16g -Xmx16g -Xss256k
-Djava.awt.headless=true -XX:+UseParNewGC -XX:+UseConcMarkSweepGC
-XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly
-XX:+HeapDumpOnOutOfMemoryError -XX:MaxPermSize=256m -Delasticsearch
-Des.pidfile=/var/run/elasticsearch/elasticsearch.pid
-Des.path.home=/usr/share/elasticsearch -cp
:/usr/share/elasticsearch/lib/elasticsearch-1.1.1.jar:/usr/share/elasticsearch/lib/:/usr/share/elasticsearch/lib/sigar/
-Des.default.path.home=/usr/share/elasticsearch
-Des.default.path.logs=/var/log/elasticsearch -Des.default.path.data=/data
-Des.default.path.work=/tmp/elasticsearch
-Des.default.path.conf=/etc/elasticsearch
org.elasticsearch.bootstrap.Elasticsearch

jstat -gc 48931

48931 not found

jmap -heap PID is working though.

Any ideas how to fix this ? I'm using JPS for one of my monitoring probe.

I'm using CentOS 6.5 with ES 1.1.1 from RPM and java 1.7

java -version

java version "1.7.0_55"
Java(TM) SE Runtime Environment (build 1.7.0_55-b13)
Java HotSpot(TM) 64-Bit Server VM (build 24.55-b03, mixed mode)

$ curl http://localhost:9200/
{
"status" : 200,
"name" : "logstash_master",
"version" : {
"number" : "1.1.1",
"build_hash" : "f1585f096d3f3985e73456debdc1a0745f512bbc",
"build_timestamp" : "2014-04-16T14:27:12Z",
"build_snapshot" : false,
"lucene_version" : "4.7"
},
"tagline" : "You Know, for Search"
}

Thanks a lot in advance,
Greg

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3792f6e6-a1fa-4658-a36e-959a2c65b52c%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Greg Bui) #2

Fixed, permission issue in /tmp

Regards,
Greg

On Thursday, May 15, 2014 5:41:41 PM UTC+2, Greg Bui wrote:

Hello,

I encounter a weird problem, jps is not returning elasticsearch whereas it
is running and (seems) working fine. I remember that was the case before.
jstat is not working as well...

jps

243157 jruby-complete-1.7.11.jar
50184 Jps

ps aux | grep elasti

494 48931 54.3 13.0 383893516 4303840 ? Sl 17:29 3:07
/usr/java/default/bin/java -Xms16g -Xmx16g -Xss256k
-Djava.awt.headless=true -XX:+UseParNewGC -XX:+UseConcMarkSweepGC
-XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly
-XX:+HeapDumpOnOutOfMemoryError -XX:MaxPermSize=256m -Delasticsearch
-Des.pidfile=/var/run/elasticsearch/elasticsearch.pid
-Des.path.home=/usr/share/elasticsearch -cp
:/usr/share/elasticsearch/lib/elasticsearch-1.1.1.jar:/usr/share/elasticsearch/lib/:/usr/share/elasticsearch/lib/sigar/
-Des.default.path.home=/usr/share/elasticsearch
-Des.default.path.logs=/var/log/elasticsearch -Des.default.path.data=/data
-Des.default.path.work=/tmp/elasticsearch
-Des.default.path.conf=/etc/elasticsearch
org.elasticsearch.bootstrap.Elasticsearch

jstat -gc 48931

48931 not found

jmap -heap PID is working though.

Any ideas how to fix this ? I'm using JPS for one of my monitoring probe.

I'm using CentOS 6.5 with ES 1.1.1 from RPM and java 1.7

java -version

java version "1.7.0_55"
Java(TM) SE Runtime Environment (build 1.7.0_55-b13)
Java HotSpot(TM) 64-Bit Server VM (build 24.55-b03, mixed mode)

$ curl http://localhost:9200/
{
"status" : 200,
"name" : "logstash_master",
"version" : {
"number" : "1.1.1",
"build_hash" : "f1585f096d3f3985e73456debdc1a0745f512bbc",
"build_timestamp" : "2014-04-16T14:27:12Z",
"build_snapshot" : false,
"lucene_version" : "4.7"
},
"tagline" : "You Know, for Search"
}

Thanks a lot in advance,
Greg

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/a27f4dd9-d2a6-4c5f-9c15-e1f9b0f2aee4%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3