Elasticsearch restart failed


(shaonbean) #1

when yum install elasticsearch && confifure yml,can start elasticsearch succeed,but when I again retsrat elasticsearch will happend errors,like example:

java.lang.IllegalStateException: detected index data in default.path.data [/var/lib/elasticsearch] where there should not be any; check the logs for details

CentOS 6.9 + elastic stack latest version.

i found through delete nodes can solve this problems,but i don't every time execute delete.


(Mark Walkom) #2

Do you mean 5.3.1?


(shaonbean) #3

yes. I add elasticsearch repo in local. su yum now is 5.3.1


(Eric Richter) #4

I have the same issue since the upgrade to 5.3.1


(shaonbean) #5

I remember 5.2.x also can't use restart elastic.


(Eric Richter) #6

I created a support case for this


(Eric Richter) #7

I removed the "-Edefault.path.data=${DATA_DIR} " parameter from the startup command and everything works fine again.

The default.data.path is defined in the elasticsearch.yml file


(Igor Marques) #8

this solve to me after update. thanks


(shaonbean) #9

but the elasticsearch version is latest


(Igor Marques) #10

yes, this start after update your elastic for latest version.
u can read some info here:
https://github.com/elastic/elasticsearch/issues/6887

and here:
https://www.elastic.co/blog/multi-data-path-bug-in-elasticsearch-5-3-0

u just need to find you elasticsearch.service and remove that line and restart.
-E default.path.data=${DATA_DIR}


(shaonbean) #11

thank you for the answer


(system) #12

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.