Elasticsearch returning blank response


(Tom Pryor) #1

Hi,

Having a strange issue when trying to get a document by id, i.e GET
to http://localhost:9200/index/type/

Sometimes Elasticsearch returns a HTTP 200 but a totally empty response.
The other strange thing is that the content-type of the response
is text/plain; charset=UTF-8 rather than the expected JSON.

This is causing major problems because when it occurs when I'm trying to
update a document my client library thinks there is no data for the
document and just indexes the document with purely the updated data,
causing data loss.

Anyone got any ideas?

Thanks.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/98d31ba6-c7fb-4151-ac6f-1f273338aa5b%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #2

Did you disable _source?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 3 mars 2014 à 14:44:58, Tom Pryor (tomwpryor@gmail.com) a écrit:

Hi,

Having a strange issue when trying to get a document by id, i.e GET to http://localhost:9200/index/type/

Sometimes Elasticsearch returns a HTTP 200 but a totally empty response. The other strange thing is that the content-type of the response is text/plain; charset=UTF-8 rather than the expected JSON.

This is causing major problems because when it occurs when I'm trying to update a document my client library thinks there is no data for the document and just indexes the document with purely the updated data, causing data loss.

Anyone got any ideas?

Thanks.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/98d31ba6-c7fb-4151-ac6f-1f273338aa5b%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.53148b77.1190cde7.50c7%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/groups/opt_out.


(Tom Pryor) #3

_source is enabled, if I fetch other documents, or fetch one of the
documents after update & data loss, the _source is present.

The response I'm occasionally seeing is completely blank (no json or
anything), just an empty string.

On Monday, March 3, 2014 2:02:31 PM UTC, David Pilato wrote:

Did you disable _source?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 3 mars 2014 à 14:44:58, Tom Pryor (tomw...@gmail.com <javascript:>) a
écrit:

Hi,

Having a strange issue when trying to get a document by id, i.e GET to
http://localhost:9200/index/type/

Sometimes Elasticsearch returns a HTTP 200 but a totally empty response.
The other strange thing is that the content-type of the response
is text/plain; charset=UTF-8 rather than the expected JSON.

This is causing major problems because when it occurs when I'm trying to
update a document my client library thinks there is no data for the
document and just indexes the document with purely the updated data,
causing data loss.

Anyone got any ideas?

Thanks.

You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/98d31ba6-c7fb-4151-ac6f-1f273338aa5b%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ae6ec54c-9fc4-4a2e-b171-91586cf73cb7%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #4

Weird.

Can you reproduce it on a clean index?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 3 mars 2014 à 15:14:19, Tom Pryor (tomwpryor@gmail.com) a écrit:

_source is enabled, if I fetch other documents, or fetch one of the documents after update & data loss, the _source is present.

The response I'm occasionally seeing is completely blank (no json or anything), just an empty string.

On Monday, March 3, 2014 2:02:31 PM UTC, David Pilato wrote:
Did you disable _source?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 3 mars 2014 à 14:44:58, Tom Pryor (tomw...@gmail.com) a écrit:

Hi,

Having a strange issue when trying to get a document by id, i.e GET to http://localhost:9200/index/type/

Sometimes Elasticsearch returns a HTTP 200 but a totally empty response. The other strange thing is that the content-type of the response is text/plain; charset=UTF-8 rather than the expected JSON.

This is causing major problems because when it occurs when I'm trying to update a document my client library thinks there is no data for the document and just indexes the document with purely the updated data, causing data loss.

Anyone got any ideas?

Thanks.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/98d31ba6-c7fb-4151-ac6f-1f273338aa5b%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ae6ec54c-9fc4-4a2e-b171-91586cf73cb7%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.53148e90.109cf92e.50c7%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/groups/opt_out.


(Tom Pryor) #5

Not tried it on a clean index but found a way around the problem. If I tell
my client library to not use persistent (i.e keep alive) connections then
this issue goes away.

On Monday, March 3, 2014 2:15:43 PM UTC, David Pilato wrote:

Weird.

Can you reproduce it on a clean index?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 3 mars 2014 à 15:14:19, Tom Pryor (tomw...@gmail.com <javascript:>) a
écrit:

_source is enabled, if I fetch other documents, or fetch one of the
documents after update & data loss, the _source is present.

The response I'm occasionally seeing is completely blank (no json or
anything), just an empty string.

On Monday, March 3, 2014 2:02:31 PM UTC, David Pilato wrote:

Did you disable _source?

 -- 

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 3 mars 2014 à 14:44:58, Tom Pryor (tomw...@gmail.com) a écrit:

Hi,

Having a strange issue when trying to get a document by id, i.e GET to
http://localhost:9200/index/type/

Sometimes Elasticsearch returns a HTTP 200 but a totally empty response.
The other strange thing is that the content-type of the response
is text/plain; charset=UTF-8 rather than the expected JSON.

This is causing major problems because when it occurs when I'm trying to
update a document my client library thinks there is no data for the
document and just indexes the document with purely the updated data,
causing data loss.

Anyone got any ideas?

Thanks.

You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/98d31ba6-c7fb-4151-ac6f-1f273338aa5b%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/ae6ec54c-9fc4-4a2e-b171-91586cf73cb7%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/74493cd0-b282-4d9f-bb0e-8d223ef61416%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #6