Elasticsearch server issue


(vallabh) #1

Dear all,

I am using elasticsearch-0.90.5.
When i run this server using following line, /bin/elasticsearch -f
It creates "data" folder in elasticsearch folder.
i.e, data/elasticsearch/nodes/0/indices
and creates index in indices folder.

When i setup same elastic server on different ip machine and run that
elasticsearch server, all index folder automatically gets copied to indices
folder in data.
That fine.

But when i wanted to delete particular index i used following line,
curl -X DELETE 'http://localhost:9200/admin' (admin is the index)

But sometimes it gives me problem while deleting this index. So i prefer to
remove index folder from indices folder.

Now my question is that,
When i run the server again on any machine, same index folder which was
deleted earlier get copied to data folder of other ip machine.
It seems that the folder is getting cache.
How many hours cache exist on the server ?

How i can manually delete the index folder.

Any suggestion is very much appreciated.

Thanks,
Vallabh

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #2

Hi,

I think you should definitely use API instead of doing manual hard drive operations.

I suppose that in your case you have 2 nodes running somewhere.
At some point, you remove your physical dir using rm -r.
When you restart elasticsearch, nodes get synchronized.

As data are missing on the second node (because you deleted them), elasticsearch copy them again.

I assume you have default settings here (5 shards / 1 replica).

There is no "data cache" as you mentioned here. It's just the basic behavior of elasticsearch when it comes to replication.

Makes sense?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

8 novembre 2013 at 13:42:38, Vallabh Bothre (vallabh.bothre@gmail.com) a écrit:

Dear all,

I am using elasticsearch-0.90.5.
When i run this server using following line, /bin/elasticsearch -f
It creates "data" folder in elasticsearch folder. i.e, data/elasticsearch/nodes/0/indices
and creates index in indices folder.

When i setup same elastic server on different ip machine and run that elasticsearch server, all index folder automatically gets copied to indices folder in data.
That fine.

But when i wanted to delete particular index i used following line,
curl -X DELETE 'http://localhost:9200/admin' (admin is the index)

But sometimes it gives me problem while deleting this index. So i prefer to remove index folder from indices folder.

Now my question is that,
When i run the server again on any machine, same index folder which was deleted earlier get copied to data folder of other ip machine.
It seems that the folder is getting cache.
How many hours cache exist on the server ?

How i can manually delete the index folder.

Any suggestion is very much appreciated.

Thanks,
Vallabh

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(vallabh) #3

Thanks very much david!! :slight_smile:

On Friday, November 8, 2013 7:24:37 PM UTC+5:30, David Pilato wrote:

Hi,

I think you should definitely use API instead of doing manual hard drive
operations.

I suppose that in your case you have 2 nodes running somewhere.
At some point, you remove your physical dir using rm -r.
When you restart elasticsearch, nodes get synchronized.

As data are missing on the second node (because you deleted them),
elasticsearch copy them again.

I assume you have default settings here (5 shards / 1 replica).

There is no "data cache" as you mentioned here. It's just the basic
behavior of elasticsearch when it comes to replication.

Makes sense?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

8 novembre 2013 at 13:42:38, Vallabh Bothre (vallabh...@gmail.com<javascript:>)
a écrit:

Dear all,

I am using elasticsearch-0.90.5.
When i run this server using following line, /bin/elasticsearch -f
It creates "data" folder in elasticsearch folder.
i.e, data/elasticsearch/nodes/0/indices
and creates index in indices folder.

When i setup same elastic server on different ip machine and run that
elasticsearch server, all index folder automatically gets copied to indices
folder in data.
That fine.

But when i wanted to delete particular index i used following line,
curl -X DELETE 'http://localhost:9200/admin' (admin is the index)

But sometimes it gives me problem while deleting this index. So i prefer
to remove index folder from indices folder.

Now my question is that,
When i run the server again on any machine, same index folder which was
deleted earlier get copied to data folder of other ip machine.
It seems that the folder is getting cache.
How many hours cache exist on the server ?

How i can manually delete the index folder.

Any suggestion is very much appreciated.

Thanks,
Vallabh

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/02fa0bb0-5087-49b3-beac-5112a9cd4d81%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #4