Elasticsearch service failed to start on CentOS


I've follow the steps in https://casesup.com/category/knowledgebase/installation/how-to-install-elasticsearch-on-linux-server to install elasticsearch in Centos 8.

but it stuck at step 3 when I tried to create service and start service, I run the service and find this error below.

[root@elk-lab ~]# systemctl status elasticsearch.service
● elasticsearch.service - Elasticsearch Service
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: >
Active: failed (Result: exit-code) since Tue 2020-09-01 10:47:13 +08; 11s ago
Process: 1965 ExecStart=/home/elksvcid/elasticsearch-7.5.1/bin/elasticsearch (code=exite>
Main PID: 1965 (code=exited, status=203/EXEC)

Kindly help what should I do to settle the issue, thanks.

Welcome to our community! :smiley:

Please check the Elasticsearch logs, there should be more there identifying the issue.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.