ElasticSearch Service Failure status=78/n/a

I have installed ElasticSearch v6.2.4 on CentOS 7.0

I have done all necessary configurations. When I run it, I got the following messages in system.

Apr 25 18:24:18 QVELKSRH01 systemd[1]: elasticsearch.service: main process exited, code=exited, status=78/n/a
Apr 25 18:24:18 QVELKSRH01 systemd[1]: Unit elasticsearch.service entered failed state.
Apr 25 18:24:18 QVELKSRH01 systemd[1]: elasticsearch.service failed.

How can I solve the problem? Thanks.

You have installed but have you configured Elasticsearch? What is in your elasticsearch.yml

I have configured elasticsearch.

The content of elasticsearch.yml is as below,

# ======================== Elasticsearch Configuration =========================
# NOTE: Elasticsearch comes with reasonable defaults for most settings.
#       Before you set out to tweak and tune the configuration, make sure you
#       understand what are you trying to accomplish and the consequences.
# The primary way of configuring a node is via this file. This template lists
# the most important settings you may want to configure for a production cluster                                                                                        .
# Please consult the documentation for further information on configuration opti                                                                                        ons:
# https://www.elastic.co/guide/en/elasticsearch/reference/index.html
# ---------------------------------- Cluster -----------------------------------
# Use a descriptive name for your cluster:
#cluster.name: Elastic Search
# ------------------------------------ Node ------------------------------------
# Use a descriptive name for the node
node.name: QVELKSRH01
# Add custom attributes to the node:
#node.attr.rack: r1
# ----------------------------------- Paths ------------------------------------
# Path to directory where to store the data (separate multiple locations by comm                                                                                        a):
path.data: /var/lib/elasticsearch
# Path to log files:
path.logs: /var/log/elasticsearch
# ----------------------------------- Memory -----------------------------------
# Lock the memory on startup:
#bootstrap.memory_lock: true
bootstrp.system_call_filter: false
# Make sure that the heap size is set to about half the memory available
# on the system and that the owner of the process is allowed to use this
# limit.
# Elasticsearch performs poorly when the system is swapping the memory.
# ---------------------------------- Network -----------------------------------
# Set the bind address to a specific IP (IPv4 or IPv6):
# Set a custom port for HTTP:
http.port: 9200
# For more information, consult the network module documentation.
# --------------------------------- Discovery ----------------------------------
# Pass an initial list of hosts to perform discovery when new node is started:
# The default list of hosts is ["", "[::1]"]
#discovery.zen.ping.unicast.hosts: [,""]
# Prevent the "split brain" by configuring the majority of nodes (total number o                                                                                        f master-eligible nodes / 2 + 1):
#discovery.zen.minimum_master_nodes = 1:
# For more information, consult the zen discovery module documentation.
# ---------------------------------- Gateway -----------------------------------
# Block initial recovery after a full cluster restart until N nodes are started:
#gateway.recover_after_nodes: 3
# For more information, consult the gateway module documentation.
# ---------------------------------- Various -----------------------------------
# Require explicit names when deleting indices:
#action.destructive_requires_name: true

What's wrong in the configuration?

bootstrp ?

1 Like

I have corrected it but it keeps starting and the connection (port 9200) is refused. I don't know how to solve.

From systems service log, It is still starting stage for long tim

Apr 27 11:31:35 QVELKSRH01 systemd[1]: Stopping Elasticsearch.
Apr 27 11:31:35 QVELKSRH01 systemd[1]: Started Elasticsearch.e
Apr 27 11:31:35 QVELKSRH01 systemd[1]: Starting Elasticsearch.

From the elasticsearch.log,

[2018-04-27T11:31:35,292][INFO ][o.e.n.Node               ] [QVELKSRH01] stopping ...
[2018-04-27T11:31:35,331][INFO ][o.e.n.Node               ] [QVELKSRH01] stopped
[2018-04-27T11:31:35,332][INFO ][o.e.n.Node               ] [QVELKSRH01] closing ...
[2018-04-27T11:31:35,345][INFO ][o.e.n.Node               ] [QVELKSRH01] closed
[2018-04-27T11:31:37,713][INFO ][o.e.n.Node               ] [QVELKSRH01] initializing ...
[2018-04-27T11:31:37,787][INFO ][o.e.e.NodeEnvironment    ] [QVELKSRH01] using [1] data paths, mounts [[/ (rootfs)]], net usable_space [48.7gb], net total_space [49.9gb], types [rootfs]
[2018-04-27T11:31:37,787][INFO ][o.e.e.NodeEnvironment    ] [QVELKSRH01] heap size [1.9gb], compressed ordinary object pointers [true]
[2018-04-27T11:31:37,788][INFO ][o.e.n.Node               ] [QVELKSRH01] node name [QVELKSRH01], node ID [FndpeyYfQ6Oo_U-F8aQusg]
[2018-04-27T11:31:37,788][INFO ][o.e.n.Node               ] [QVELKSRH01] version[6.2.4], pid[12014], build[ccec39f/2018-04-12T20:37:28.497551Z], OS[Linux/3.10.0-693.el7.x86_64/amd64], JVM[Oracle Corporation/Java HotSpot(TM) 64-Bit Server VM/1.8.0_171/25.171-b11]
[2018-04-27T11:31:37,788][INFO ][o.e.n.Node               ] [QVELKSRH01] JVM arguments [-Xms2g, -Xmx2g, -XX:+UseConcMarkSweepGC, -XX:CMSInitiatingOccupancyFraction=75, -XX:+UseCMSInitiatingOccupancyOnly, -XX:+AlwaysPreTouch, -Xss1m, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djna.nosys=true, -XX:-OmitStackTraceInFastThrow, -Dio.netty.noUnsafe=true, -Dio.netty.noKeySetOptimization=true, -Dio.netty.recycler.maxCapacityPerThread=0, -Dlog4j.shutdownHookEnabled=false, -Dlog4j2.disable.jmx=true, -Djava.io.tmpdir=/tmp/elasticsearch.EvFo8Q0n, -XX:+HeapDumpOnOutOfMemoryError, -XX:HeapDumpPath=/var/lib/elasticsearch, -XX:+PrintGCDetails, -XX:+PrintGCDateStamps, -XX:+PrintTenuringDistribution, -XX:+PrintGCApplicationStoppedTime, -Xloggc:/var/log/elasticsearch/gc.log, -XX:+UseGCLogFileRotation, -XX:NumberOfGCLogFiles=32, -XX:GCLogFileSize=64m, -Des.path.home=/usr/share/elasticsearch, -Des.path.conf=/etc/elasticsearch]
[2018-04-27T11:31:38,504][INFO ][o.e.p.PluginsService     ] [QVELKSRH01] loaded module [aggs-matrix-stats]
[2018-04-27T11:31:38,505][INFO ][o.e.p.PluginsService     ] [QVELKSRH01] loaded module [analysis-common]
[2018-04-27T11:31:38,505][INFO ][o.e.p.PluginsService     ] [QVELKSRH01] loaded module [ingest-common]
[2018-04-27T11:31:38,505][INFO ][o.e.p.PluginsService     ] [QVELKSRH01] loaded module [lang-expression]
[2018-04-27T11:31:38,505][INFO ][o.e.p.PluginsService     ] [QVELKSRH01] loaded module [lang-mustache]
[2018-04-27T11:31:38,505][INFO ][o.e.p.PluginsService     ] [QVELKSRH01] loaded module [lang-painless]
[2018-04-27T11:31:38,505][INFO ][o.e.p.PluginsService     ] [QVELKSRH01] loaded module [mapper-extras]
[2018-04-27T11:31:38,505][INFO ][o.e.p.PluginsService     ] [QVELKSRH01] loaded module [parent-join]
[2018-04-27T11:31:38,505][INFO ][o.e.p.PluginsService     ] [QVELKSRH01] loaded module [percolator]
[2018-04-27T11:31:38,505][INFO ][o.e.p.PluginsService     ] [QVELKSRH01] loaded module [rank-eval]
[2018-04-27T11:31:38,505][INFO ][o.e.p.PluginsService     ] [QVELKSRH01] loaded module [reindex]
[2018-04-27T11:31:38,505][INFO ][o.e.p.PluginsService     ] [QVELKSRH01] loaded module [repository-url]
[2018-04-27T11:31:38,505][INFO ][o.e.p.PluginsService     ] [QVELKSRH01] loaded module [transport-netty4]
[2018-04-27T11:31:38,505][INFO ][o.e.p.PluginsService     ] [QVELKSRH01] loaded module [tribe]
[2018-04-27T11:31:38,506][INFO ][o.e.p.PluginsService     ] [QVELKSRH01] no plugins loaded
[2018-04-27T11:31:40,781][INFO ][o.e.d.DiscoveryModule    ] [QVELKSRH01] using discovery type [zen]
[2018-04-27T11:31:41,194][INFO ][o.e.n.Node               ] [QVELKSRH01] initialized
[2018-04-27T11:31:41,194][INFO ][o.e.n.Node               ] [QVELKSRH01] starting ...
[2018-04-27T11:31:41,391][INFO ][o.e.t.TransportService   ] [QVELKSRH01] publish_address {}, bound_addresses {}
[2018-04-27T11:31:41,409][INFO ][o.e.b.BootstrapChecks    ] [QVELKSRH01] bound or publishing to a non-loopback address, enforcing bootstrap checks
[2018-04-27T11:31:44,492][INFO ][o.e.c.s.MasterService    ] [QVELKSRH01] zen-disco-elected-as-master ([0] nodes joined), reason: new_master {QVELKSRH01}{FndpeyYfQ6Oo_U-F8aQusg}{9gzDrupuR5SiVRSJ7we5MA}{}{}
[2018-04-27T11:31:44,501][INFO ][o.e.c.s.ClusterApplierService] [QVELKSRH01] new_master {QVELKSRH01}{FndpeyYfQ6Oo_U-F8aQusg}{9gzDrupuR5SiVRSJ7we5MA}{}{}, reason: apply cluster state (from master [master {QVELKSRH01}{FndpeyYfQ6Oo_U-F8aQusg}{9gzDrupuR5SiVRSJ7we5MA}{}{} committed version [1] source [zen-disco-elected-as-master ([0] nodes joined)]])
[2018-04-27T11:31:44,524][INFO ][o.e.h.n.Netty4HttpServerTransport] [QVELKSRH01] publish_address {}, bound_addresses {}
[2018-04-27T11:31:44,525][INFO ][o.e.n.Node               ] [QVELKSRH01] started
[2018-04-27T11:31:44,537][INFO ][o.e.g.GatewayService     ] [QVELKSRH01] recovered [0] indices into cluster_state

Run that from the machine where elasticsearch has been started:


It shows some output with attributes.

I just wonder why I can't access through web browser

After this, what steps should I follow then? I'm a bit getting lost.


So everything is working well on elasticsearch side as the logs suggest.

May be look if you have a proxy defined in your browser, a firewall somewhere...
And if it does not work, share what you are exactly doing in the browser. Which URL?

I try to access it via in the same network bypassing proxy and firewall.

Nothing is displayed.

I can't tell. If elasticsearch is working with:


Then you have a problem on your end. Double check that you can access this machine from your laptop by like doing a telnet or curl from your machine on port 9200.

I can ping it but unable to telnet it via port 9200.

Any setting also needs to be changed?

@thompsonlau as @dadoonet has kindly pointed out, are you able to curl ?

Found the problem. The CentOS firewall block it.

I now can access the page via web browser. Then what part of procedures should I move on to configure elasticsearch?

from here go forth with https://www.elastic.co/guide/en/elasticsearch/reference/current/_exploring_your_cluster.html

OK thanks. Actually will ElasticSearch goes with GUI? At which step I can access UI?

Ensure Kibana is installed, started, listening on port 5601: https://www.elastic.co/guide/en/kibana/current/getting-started.html

Then and depending on your setup visit

Isn't what I said?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.