Elasticsearch service start

I want to start elasticsearch as service in linux machine. Before i was used service wrapper to start elasticsearch as service. But now i m unable to use it because im using elasticsearch 2.2.1 version. Kindly help me to sort out this issue.

I'd read this: https://www.elastic.co/guide/en/elasticsearch/reference/current/setup-service.html

@dadoonet how to create the init.d/elasticsearch script? Can you explain on that

What is your OS?

Im using linux 64 bit version

Which distribution ?

Red Hat Enterprise Linux Server release 6.4 (Santiago)

Redhat uses RPM right?
Is there anything wrong with the documentation? https://www.elastic.co/guide/en/elasticsearch/reference/current/setup-service.html#_rpm_based_distributions

Note that the RPM is here: https://www.elastic.co/downloads/elasticsearch

I tried this way while starting the service im getting this error "Failed to issue method call: Access denied" can you help to sort of it @dadoonet

No sorry. May be @warkolm could help?

HI @warkolm can you help me to sort the above mentioned issue

Please don't post pictures of text, it makes it difficult to read.

Are you root when running that command, cause you need to be. Run those other two commands as it suggests and see what is reported.

@warkolm yes i'm running as root user and still it replicating the same error my screen.

hi guys,

even i am getting the same error while starting the elasticsearch"Failed to issue method call: Unit elasticsearch.service failed to load: No such file or directory"

i am using the elasticsearch 2.2.1 version. on redhat 7

please help me guys

HI Lavanya,

I think you disable the Elasticsearch service Please enable it by giving below command.

systemctl enable elasticsearch.service

It's clear from the picture (sh$) that the first time service elasticsearch start was run, it was not as the root user and not with sudo. I could imagine that's why systemctl threw the error message.

HI @unknownunknown i'm having the root permission to do all the process in the server.

@usahitya I have done tat command also even though facing same issue. initially reload the deamon and enable the service and start the service i tried this way.