Elasticsearch shards not able to set 1

I try to change the shards by default from 5 to 1 using settings options like this..

"number_of_shards": 1,
"number_of_replicas": 0

"settings": {
"analysis": {
"filter": {

its' showing acknowledgement true...but when I checked on using curl...it again showing shards 5 and replica 1. Why it not change....

You cannot change the shard count once the index is created.

Hi warkolm..

But I am changing shards index time..not after...creation...

When are you sending this to Elasticsearch, how are you sending it?

Sir, I am sending it to using curl...while doing settings and mapping....itself....when I am sending it through kibana..it saying acknowledgement true.....but when checking through settings options...shards again 5....

please provide a full reproduction of all your steps. All the curl calls you did. Otherwise it is impossible yo help you.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.