Elasticsearch - special character search (using elastic gui/head)


(Karthik) #1

Hi

I'm fairly new to elasticsearch and I'm trying to use fsriver to import
bunch of text files into elasticsearch. Below's how I do it

curl -XPUT 'http://localhost:9200/mydocs/'


curl -XPUT 'http://localhost:9200/mydocs/doc/_mapping' -d '{
"doc" : {
"properties" : {
"content" : {
"index" : "not_analyzed",
"type" : "string",
"store" : "yes"
}
}
}
}'


curl -XPUT 'localhost:9200/_river/txt/_meta' -d '{
"type": "fs",
"fs": {
"name": "fs river",
"url": "C:\TEST",
"update_rate": "1hr",
"includes": "*.txt"
},
"index": {"index": "mydocs","type": "doc"}
}'

Later when I try to search the content inside the txt files using elastic
gui with special character I get different results. I'm not getting the
exact matches but instead it returns huge piles of data.

For example one of my txt files contains string like

"%25%25%25%25%25%25%25%25%25%25%25%25%25%25%25%25%25%25"
"%26%26%26%26%26%26%26%26%26%26%26%26%26%26%26%26%26%26"

in separate lines. When I search (using elastic gui/head) for "%25%25%25" I
get results from files that contain just the number '25' too. Please can
someone point out what's wrong with my settings?

Thanks
Karthik

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e6cfecdd-ec22-40e2-a582-51f209e8bb7e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #2