Elasticsearch Startup issues


(P lva) #1

I get this error at elasticsearch startup

Exception in thread "main" java.lang.NoClassDefFoundError:
org.apache.lucene.util.Version
at org.elasticsearch.Version.(Version.java:42)
at java.lang.Class.initializeClass(libgcj.so.10)
at
org.elasticsearch.bootstrap.Bootstrap.buildErrorMessage(Bootstrap.java:252)
at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:178)
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:32)

The jar containing this class is present in the lib directory and echo
$ES_CLASSPATH shows this jar.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/fd314c1e-a78a-4d93-a1e4-5c442fab1bee%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Alexander Reelsen) #2

Hey,

can you be more verbose, how you are actually starting elasticsearch, which
version you are using, what operating system you are running on, which java
version you are running, what is your default shell? Did you modify
anything from the standard installation?
Thanks.

--Alex

On Tue, Mar 11, 2014 at 11:38 PM, P lva ruvikal@gmail.com wrote:

I get this error at elasticsearch startup

Exception in thread "main" java.lang.NoClassDefFoundError:
org.apache.lucene.util.Version
at org.elasticsearch.Version.(Version.java:42)
at java.lang.Class.initializeClass(libgcj.so.10)
at
org.elasticsearch.bootstrap.Bootstrap.buildErrorMessage(Bootstrap.java:252)
at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:178)
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:32)

The jar containing this class is present in the lib directory and echo
$ES_CLASSPATH shows this jar.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/fd314c1e-a78a-4d93-a1e4-5c442fab1bee%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/fd314c1e-a78a-4d93-a1e4-5c442fab1bee%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGCwEM_K6_mpR5ZgB0Xk8V-TCKCwQj7%2BVKVRYNmVAgCxbOyb%3DA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(P lva) #3

Apart from cluster name and node name I didnt change anything.
Version 1.0.1
Commands I use to start bin/elasticsearch

On Wednesday, March 12, 2014 5:20:56 AM UTC-5, Alexander Reelsen wrote:

Hey,

can you be more verbose, how you are actually starting elasticsearch,
which version you are using, what operating system you are running on,
which java version you are running, what is your default shell? Did you
modify anything from the standard installation?
Thanks.

--Alex

On Tue, Mar 11, 2014 at 11:38 PM, P lva <ruv...@gmail.com <javascript:>>wrote:

I get this error at elasticsearch startup

Exception in thread "main" java.lang.NoClassDefFoundError:
org.apache.lucene.util.Version
at org.elasticsearch.Version.(Version.java:42)
at java.lang.Class.initializeClass(libgcj.so.10)
at
org.elasticsearch.bootstrap.Bootstrap.buildErrorMessage(Bootstrap.java:252)
at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:178)
at
org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:32)

The jar containing this class is present in the lib directory and echo
$ES_CLASSPATH shows this jar.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/fd314c1e-a78a-4d93-a1e4-5c442fab1bee%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/fd314c1e-a78a-4d93-a1e4-5c442fab1bee%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b489cd4a-cb33-45f6-9ff5-fb99dd4429eb%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(P lva) #4

I have
RHEL 6.
Java 1.7
default shell is bash.
I tried it on a server, it worked fine right out of the box, but when I
moved to the actual set of servers it failed.
Its got something to do with environment for sure, but I can't figure out
what.

On Wednesday, March 12, 2014 5:20:56 AM UTC-5, Alexander Reelsen wrote:

Hey,

can you be more verbose, how you are actually starting elasticsearch,
which version you are using, what operating system you are running on,
which java version you are running, what is your default shell? Did you
modify anything from the standard installation?
Thanks.

--Alex

On Tue, Mar 11, 2014 at 11:38 PM, P lva <ruv...@gmail.com <javascript:>>wrote:

I get this error at elasticsearch startup

Exception in thread "main" java.lang.NoClassDefFoundError:
org.apache.lucene.util.Version
at org.elasticsearch.Version.(Version.java:42)
at java.lang.Class.initializeClass(libgcj.so.10)
at
org.elasticsearch.bootstrap.Bootstrap.buildErrorMessage(Bootstrap.java:252)
at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:178)
at
org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:32)

The jar containing this class is present in the lib directory and echo
$ES_CLASSPATH shows this jar.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/fd314c1e-a78a-4d93-a1e4-5c442fab1bee%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/fd314c1e-a78a-4d93-a1e4-5c442fab1bee%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ccb52426-5681-4505-b08f-8233ba0d78ef%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Jörg Prante) #5

How do you start Elasticsearch, by

$ cd $ES_HOME
$ ./bin/elasticsearch

or

$ cd $ES_HOME/bin
$ ./elasticsearch

or

...

?

Jörg

On Wed, Mar 12, 2014 at 8:12 PM, P lva ruvikal@gmail.com wrote:

I have
RHEL 6.
Java 1.7
default shell is bash.
I tried it on a server, it worked fine right out of the box, but when I
moved to the actual set of servers it failed.
Its got something to do with environment for sure, but I can't figure out
what.

On Wednesday, March 12, 2014 5:20:56 AM UTC-5, Alexander Reelsen wrote:

Hey,

can you be more verbose, how you are actually starting elasticsearch,
which version you are using, what operating system you are running on,
which java version you are running, what is your default shell? Did you
modify anything from the standard installation?
Thanks.

--Alex

On Tue, Mar 11, 2014 at 11:38 PM, P lva ruv...@gmail.com wrote:

I get this error at elasticsearch startup

Exception in thread "main" java.lang.NoClassDefFoundError:
org.apache.lucene.util.Version
at org.elasticsearch.Version.(Version.java:42)
at java.lang.Class.initializeClass(libgcj.so.10)
at org.elasticsearch.bootstrap.Bootstrap.buildErrorMessage(
Bootstrap.java:252)
at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:178)
at org.elasticsearch.bootstrap.Elasticsearch.main(
Elasticsearch.java:32)

The jar containing this class is present in the lib directory and echo
$ES_CLASSPATH shows this jar.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/fd314c1e-a78a-4d93-a1e4-5c442fab1bee%
40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/fd314c1e-a78a-4d93-a1e4-5c442fab1bee%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/ccb52426-5681-4505-b08f-8233ba0d78ef%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/ccb52426-5681-4505-b08f-8233ba0d78ef%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoFCw0KAWTSd7L3gwrYPiwUXEaS%2B0RGH_0oAyRYeP5GYWw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Jörg Prante) #6

And do you start Elasticsearch by the same user you installed Elasticsearch
under?

Jörg

On Wed, Mar 12, 2014 at 8:19 PM, joergprante@gmail.com <
joergprante@gmail.com> wrote:

How do you start Elasticsearch, by

$ cd $ES_HOME
$ ./bin/elasticsearch

or

$ cd $ES_HOME/bin
$ ./elasticsearch

or

...

?

Jörg

On Wed, Mar 12, 2014 at 8:12 PM, P lva ruvikal@gmail.com wrote:

I have
RHEL 6.
Java 1.7
default shell is bash.
I tried it on a server, it worked fine right out of the box, but when I
moved to the actual set of servers it failed.
Its got something to do with environment for sure, but I can't figure out
what.

On Wednesday, March 12, 2014 5:20:56 AM UTC-5, Alexander Reelsen wrote:

Hey,

can you be more verbose, how you are actually starting elasticsearch,
which version you are using, what operating system you are running on,
which java version you are running, what is your default shell? Did you
modify anything from the standard installation?
Thanks.

--Alex

On Tue, Mar 11, 2014 at 11:38 PM, P lva ruv...@gmail.com wrote:

I get this error at elasticsearch startup

Exception in thread "main" java.lang.NoClassDefFoundError:
org.apache.lucene.util.Version
at org.elasticsearch.Version.(Version.java:42)
at java.lang.Class.initializeClass(libgcj.so.10)
at org.elasticsearch.bootstrap.Bootstrap.buildErrorMessage(
Bootstrap.java:252)
at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:178)
at org.elasticsearch.bootstrap.Elasticsearch.main(
Elasticsearch.java:32)

The jar containing this class is present in the lib directory and echo
$ES_CLASSPATH shows this jar.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/fd314c1e-a78a-4d93-a1e4-5c442fab1bee%
40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/fd314c1e-a78a-4d93-a1e4-5c442fab1bee%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/ccb52426-5681-4505-b08f-8233ba0d78ef%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/ccb52426-5681-4505-b08f-8233ba0d78ef%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoFWNTxPB57aCwv5cZkH8VdeosgaM1a7hnae%2BZyQvp_c6g%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(P lva) #7

I didnt want elasticsearch to be under a user's directory so I have it in
/usr/lib/elasticsearch. All the files are owned by the non root user that
is running the command
bash /usr/lib/elasticsearch/bin/elasticsearch

On Wednesday, March 12, 2014 2:21:41 PM UTC-5, Jörg Prante wrote:

And do you start Elasticsearch by the same user you installed
Elasticsearch under?

Jörg

On Wed, Mar 12, 2014 at 8:19 PM, joerg...@gmail.com <javascript:> <
joerg...@gmail.com <javascript:>> wrote:

How do you start Elasticsearch, by

$ cd $ES_HOME
$ ./bin/elasticsearch

or

$ cd $ES_HOME/bin
$ ./elasticsearch

or

...

?

Jörg

On Wed, Mar 12, 2014 at 8:12 PM, P lva <ruv...@gmail.com <javascript:>>wrote:

I have
RHEL 6.
Java 1.7
default shell is bash.
I tried it on a server, it worked fine right out of the box, but when I
moved to the actual set of servers it failed.
Its got something to do with environment for sure, but I can't figure
out what.

On Wednesday, March 12, 2014 5:20:56 AM UTC-5, Alexander Reelsen wrote:

Hey,

can you be more verbose, how you are actually starting elasticsearch,
which version you are using, what operating system you are running on,
which java version you are running, what is your default shell? Did you
modify anything from the standard installation?
Thanks.

--Alex

On Tue, Mar 11, 2014 at 11:38 PM, P lva ruv...@gmail.com wrote:

I get this error at elasticsearch startup

Exception in thread "main" java.lang.NoClassDefFoundError:
org.apache.lucene.util.Version
at org.elasticsearch.Version.(Version.java:42)
at java.lang.Class.initializeClass(libgcj.so.10)
at org.elasticsearch.bootstrap.Bootstrap.buildErrorMessage(
Bootstrap.java:252)
at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:178)
at org.elasticsearch.bootstrap.Elasticsearch.main(
Elasticsearch.java:32)

The jar containing this class is present in the lib directory and echo
$ES_CLASSPATH shows this jar.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/fd314c1e-a78a-4d93-a1e4-5c442fab1bee%
40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/fd314c1e-a78a-4d93-a1e4-5c442fab1bee%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/ccb52426-5681-4505-b08f-8233ba0d78ef%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/ccb52426-5681-4505-b08f-8233ba0d78ef%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/412cb050-aecf-4309-b230-db2d538ddd12%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Jörg Prante) #8

The script elasticsearch, how you call it with absolute path under system
dir /usr/lib, has problems in traversing the path to find the parent folder
and set the variable ES_HOME.

You should use an init script, like provided by the distributions or the
service wrapper, with preconfigured environment, so ES_HOME and
ES_CLASSPATH (i.e. the $ES_HOME/lib folder) can be used.

Jörg

On Wed, Mar 12, 2014 at 8:44 PM, P lva ruvikal@gmail.com wrote:

I didnt want elasticsearch to be under a user's directory so I have it in
/usr/lib/elasticsearch. All the files are owned by the non root user that
is running the command
bash /usr/lib/elasticsearch/bin/elasticsearch

On Wednesday, March 12, 2014 2:21:41 PM UTC-5, Jörg Prante wrote:

And do you start Elasticsearch by the same user you installed
Elasticsearch under?

Jörg

On Wed, Mar 12, 2014 at 8:19 PM, joerg...@gmail.com joerg...@gmail.comwrote:

How do you start Elasticsearch, by

$ cd $ES_HOME
$ ./bin/elasticsearch

or

$ cd $ES_HOME/bin
$ ./elasticsearch

or

...

?

Jörg

On Wed, Mar 12, 2014 at 8:12 PM, P lva ruv...@gmail.com wrote:

I have
RHEL 6.
Java 1.7
default shell is bash.
I tried it on a server, it worked fine right out of the box, but when I
moved to the actual set of servers it failed.
Its got something to do with environment for sure, but I can't figure
out what.

On Wednesday, March 12, 2014 5:20:56 AM UTC-5, Alexander Reelsen wrote:

Hey,

can you be more verbose, how you are actually starting elasticsearch,
which version you are using, what operating system you are running on,
which java version you are running, what is your default shell? Did you
modify anything from the standard installation?
Thanks.

--Alex

On Tue, Mar 11, 2014 at 11:38 PM, P lva ruv...@gmail.com wrote:

I get this error at elasticsearch startup

Exception in thread "main" java.lang.NoClassDefFoundError:
org.apache.lucene.util.Version
at org.elasticsearch.Version.(Version.java:42)
at java.lang.Class.initializeClass(libgcj.so.10)
at org.elasticsearch.bootstrap.Bootstrap.buildErrorMessage(Boot
strap.java:252)
at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:178)
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch
.java:32)

The jar containing this class is present in the lib directory and
echo $ES_CLASSPATH shows this jar.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/fd314c1e-a78a-4d93-a1e4-5c442fab1bee%40goo
glegroups.comhttps://groups.google.com/d/msgid/elasticsearch/fd314c1e-a78a-4d93-a1e4-5c442fab1bee%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/ccb52426-5681-4505-b08f-8233ba0d78ef%
40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/ccb52426-5681-4505-b08f-8233ba0d78ef%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/412cb050-aecf-4309-b230-db2d538ddd12%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/412cb050-aecf-4309-b230-db2d538ddd12%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoH35FjFWvzA0MdNrg0EF_hHcPTsrBwYXT-skBEUy5D77Q%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(P lva) #9

It worked fine after manually setting all the environment variables.

I would say this though.
Server a : ES out of box works from home dir.
Server b : ES out of box neither works from /usr/lib/ nor does it work from
home dir. Only way is to manually set env parameters.
Both servers are built identically.

On Wednesday, March 12, 2014 2:57:57 PM UTC-5, Jörg Prante wrote:

The script elasticsearch, how you call it with absolute path under system
dir /usr/lib, has problems in traversing the path to find the parent folder
and set the variable ES_HOME.

You should use an init script, like provided by the distributions or the
service wrapper, with preconfigured environment, so ES_HOME and
ES_CLASSPATH (i.e. the $ES_HOME/lib folder) can be used.

Jörg

On Wed, Mar 12, 2014 at 8:44 PM, P lva <ruv...@gmail.com <javascript:>>wrote:

I didnt want elasticsearch to be under a user's directory so I have it in
/usr/lib/elasticsearch. All the files are owned by the non root user that
is running the command
bash /usr/lib/elasticsearch/bin/elasticsearch

On Wednesday, March 12, 2014 2:21:41 PM UTC-5, Jörg Prante wrote:

And do you start Elasticsearch by the same user you installed
Elasticsearch under?

Jörg

On Wed, Mar 12, 2014 at 8:19 PM, joerg...@gmail.com joerg...@gmail.comwrote:

How do you start Elasticsearch, by

$ cd $ES_HOME
$ ./bin/elasticsearch

or

$ cd $ES_HOME/bin
$ ./elasticsearch

or

...

?

Jörg

On Wed, Mar 12, 2014 at 8:12 PM, P lva ruv...@gmail.com wrote:

I have
RHEL 6.
Java 1.7
default shell is bash.
I tried it on a server, it worked fine right out of the box, but when
I moved to the actual set of servers it failed.
Its got something to do with environment for sure, but I can't figure
out what.

On Wednesday, March 12, 2014 5:20:56 AM UTC-5, Alexander Reelsen wrote:

Hey,

can you be more verbose, how you are actually starting elasticsearch,
which version you are using, what operating system you are running on,
which java version you are running, what is your default shell? Did you
modify anything from the standard installation?
Thanks.

--Alex

On Tue, Mar 11, 2014 at 11:38 PM, P lva ruv...@gmail.com wrote:

I get this error at elasticsearch startup

Exception in thread "main" java.lang.NoClassDefFoundError:
org.apache.lucene.util.Version
at org.elasticsearch.Version.(Version.java:42)
at java.lang.Class.initializeClass(libgcj.so.10)
at org.elasticsearch.bootstrap.Bootstrap.buildErrorMessage(Boot
strap.java:252)
at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:178)
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch
.java:32)

The jar containing this class is present in the lib directory and
echo $ES_CLASSPATH shows this jar.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/fd314c1e-a78
a-4d93-a1e4-5c442fab1bee%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/fd314c1e-a78a-4d93-a1e4-5c442fab1bee%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/ccb52426-5681-4505-b08f-8233ba0d78ef%
40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/ccb52426-5681-4505-b08f-8233ba0d78ef%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/412cb050-aecf-4309-b230-db2d538ddd12%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/412cb050-aecf-4309-b230-db2d538ddd12%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/add0ad6a-83d3-46c7-a440-9d3a5dbdc8a5%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #10