Elasticsearch stopping and getting network exception

Hello,

I have deployed single node on machine, while starting the elasticsearch is getting stopped and returns and exception no-up and running site-local private address found, got...

Please find the below log of ES.

No up-and-running site-local (private) addresses found, got [name:lo (lo), name:eth0 (eth0), name:eth1(eth1)] at org.elasticsearch.common.network.NetworkUtils.getSiteLocalAddresses

I have tried to add network.host: 0.0.0.0 also network.host: IP address but still getting the same error. Please let me know how I can proceed further and is any network causing this issue.

It's hard to tell from the fragments of information you've shared, but I think this means something is configured to use _site_ or a variant, but you have no site-local addresses on this machine.

Hello,
Thanks for the help.

I have made the changes in elasticsearch.yml in transport.host, I have changed site to local and the es got started.

As I'm a beginner, could you let me know what function does transport.host does and if there is any issue if there are multiple interfaces on the host machine.

Regards,
Shubham Hate

I do not recommend setting transport.host -- you should normally set network.host instead. These docs describe what it does.

No problem with multiple instances on the host machine as long as you use network.host to select the right interface.