Elasticsearch stops working suddenly


(mehdi) #1
  • deleted -

(Mark Walkom) #2

Take a look at http://www.elasticsearch.org/tutorials/too-many-open-files/

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 23 February 2014 06:08, Mehdi medyo4zy@gmail.com wrote:

I have deployed Elasticsearch on a development ubunto VPS. We use that VPS
only to host Api for mobile apps.

Everything worked good till today, elasticsearch stops working. I tried to
restart it, it says Server ok but when i check the status it gives me : is
not running.

The Ruby on Rails app log contains : Errno::ECONNREFUSED (Connection
refused - connect(2)) After that, i start getting this error : Too many
open files

Does anyone can help me ? Thanks

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/c8481e98-bc29-4846-bb87-18988dfe41fe%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624ZrcO_QVqfMrKUY9qy3%3DQB_gfQFtokew6MDxNk7jXP3DQ%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(mehdi) #3

Already tried

Le samedi 22 février 2014 22:00:51 UTC, Mark Walkom a écrit :

Take a look at http://www.elasticsearch.org/tutorials/too-many-open-files/

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com <javascript:>
web: www.campaignmonitor.com

On 23 February 2014 06:08, Mehdi <medy...@gmail.com <javascript:>> wrote:

I have deployed Elasticsearch on a development ubunto VPS. We use that
VPS only to host Api for mobile apps.

Everything worked good till today, elasticsearch stops working. I tried
to restart it, it says Server ok but when i check the status it gives me :
is not running.

The Ruby on Rails app log contains : Errno::ECONNREFUSED (Connection
refused - connect(2)) After that, i start getting this error : Too many
open files

Does anyone can help me ? Thanks

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/c8481e98-bc29-4846-bb87-18988dfe41fe%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/637920e5-4b6a-4de6-bd4b-4ab164f24c6e%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Alexander Reelsen) #4

Hey,

please be more verbose than that. Use the nodes stats and nodes info APIs
to find out how many files the elasticsearch process is allowed to open,
and how many files are open. Show us the output here.
Any special linux distribution or any special security settings which might
prevent setting the max open file descriptors? Please check the max open
files settings in your configuration file as well:
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/setup-service.html#_linux

Happy to hear back!

--Alex

On Sun, Feb 23, 2014 at 12:03 AM, Mehdi medyo4zy@gmail.com wrote:

Already tried

Le samedi 22 février 2014 22:00:51 UTC, Mark Walkom a écrit :

Take a look at http://www.elasticsearch.org/tutorials/too-many-open-
files/

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com
web: www.campaignmonitor.com

On 23 February 2014 06:08, Mehdi medy...@gmail.com wrote:

I have deployed Elasticsearch on a development ubunto VPS. We use that
VPS only to host Api for mobile apps.

Everything worked good till today, elasticsearch stops working. I tried
to restart it, it says Server ok but when i check the status it gives me :
is not running.

The Ruby on Rails app log contains : Errno::ECONNREFUSED (Connection
refused - connect(2)) After that, i start getting this error : Too
many open files

Does anyone can help me ? Thanks

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/c8481e98-bc29-4846-bb87-18988dfe41fe%
40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/637920e5-4b6a-4de6-bd4b-4ab164f24c6e%40googlegroups.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGCwEM-Pvn2aqa9Pw6zSUTL7f33J%2Bg7YOUN5518b8UxZFajXpg%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #5