Elasticsearch warm phase on rollover

I created a simple policy for rollover using Kibana getting the following request:

PUT _ilm/policy/30d
{
  "policy": {
    "phases": {
      "hot": {
        "min_age": "0ms",
        "actions": {
          "rollover": {
            "max_docs": 100
          },
          "set_priority": {
            "priority": 100
          }
        }
      },
      "warm": {
        "actions": {
          "set_priority": {
            "priority": 50
          }
        }
      }
    }
  }
}

From kibana i check "Move to warm phase on rollover".
Trying with sample test i get that rollover is working fine so after reaching 100 documents it switch the index to the next setting it as write index.
From Kibana I see that the new index is correctly in "hot" phase but the old one has as current phase "completed". Why it is not in warm phase as i configured on Kibana?

Thanks.

Can you run an explain on the index?

This is the response

{
  "indices" : {
    "applications-000001" : {
      "index" : "applications-000001",
      "managed" : true,
      "policy" : "30d",
      "lifecycle_date_millis" : 1617814285452,
      "age" : "15.12h",
      "phase" : "completed",
      "phase_time_millis" : 1617814285920,
      "action" : "completed",
      "action_time_millis" : 1617814285920,
      "step" : "completed",
      "step_time_millis" : 1617814285920,
      "phase_execution" : {
        "policy" : "30d",
        "version" : 9,
        "modified_date_in_millis" : 1617802613191
      }
    }
  }
}