Elasticsearch0.90.5 gpf on linux


(Greg Mowery) #1

I am doing some testing/POC code on moving a current SOLR solution to an
ElasticSeach based search. In testing, I am running into a problem when
trying to indexing a document.

OS: SUSE Linux Enterprise Server 11 (x86_64) running in a virtualized mode
java version: jdk1.6.0_29
es version: 0.90.5

I am using the transportclient in java:

address = CFactory.instance().getProperty("elastic.address");

 try
 {
   
   Settings settings = ImmutableSettings.settingsBuilder()
       .put("cluster.name", "esS1").build();

   client =    new TransportClient(settings);

 client.addTransportAddress(new InetSocketTransportAddress(address, 9300

));

No problems here

I then generate a map of fields/values.

if(indexableData == null)
indexableData = new HashMap<String,Object>();

indexableData.clear();

indexableData.put(IDocumentIndexableFields.TITLE, getTitle());
indexableData.put(IDocumentIndexableFields.AUTHORNAMES,getAuthorsForIndexing

());
indexableData.put(IDocumentIndexableFields.DOCUMENTID, getId());
indexableData.put(IDocumentIndexableFields.DOCUMENTNO, getDocumentNo());
indexableData.put(IDocumentIndexableFields.CONFIGID, getConfigId().
toString());
int[] groups = getGroupIds(user);
if(groups != null)
indexableData.put(IDocumentIndexableFields.GROUPNO, groups);
indexableData.put(IDocumentIndexableFields.STACKID, user.getConfig().
getParameterValue(IConfigParameterName.PRODUCTION_STACK_ID));

return indexableData;

I then send the map to the client

Map fields = obj.getFieldData(user);
try
{
response = client.prepareIndex(root, obj.getObjName(),obj.
generateIndexId(user))
.setSource(fields)
.execute()
.actionGet();
}

The log from elasticsearch registers this:
[2013-10-17 09:05:32,885][DEBUG][action.index ] [Hijacker]
Sending mapping updated to master: index [s1m.dev] type [document]

Then I get a GPF

Unhandled exception
Type=Segmentation error vmState=0x00000000
J9Generic_Signal_Number=00000004 Signal_Number=0000000b Error_Value=00000000
Signal_Code=00000080
Handler1=00002B4F399564C0 Handler2=00002B4F39CE67F0 InaccessibleAddress=
0000000000000000
RDI=17E600830001565A RSI=0000000001046EBE RAX=000000000000003A RBX=
000000000109C400
RCX=0000000002450880 RDX=17E600830001565A R8=17E600830001565A R9=
0000000000000164
R10=0000000000000000 R11=0000000000000002 R12=00000000006E3080 R13=
0000000002425DB4
R14=00002B4F39ABB160 R15=00002B4F7DED6F20
RIP=00002B4F3B76A629 GS=0000 FS=0000 RSP=00000000024507F8
EFlags=0000000000210206 CS=0033 RBP=0000000002445C00 ERR=0000000000000000
TRAPNO=000000000000000D OLDMASK=0000000000000000 CR2=0000000000000000
xmm0 0000000000000000 (f: 0.000000, d: 0.000000e+00)
xmm1 0000000000000000 (f: 0.000000, d: 0.000000e+00)
xmm2 ffff000000000000 (f: 0.000000, d: -nan)
xmm3 0000000002445c00 (f: 38034432.000000, d: 1.879151e-316)
xmm4 00002b4f84e36bd0 (f: 2229496832.000000, d: 2.352767e-310)
xmm5 00002b4f7ef53180 (f: 2129998208.000000, d: 2.352762e-310)
xmm6 00002b4f39abb160 (f: 967553408.000000, d: 2.352705e-310)
xmm7 0000000000000102 (f: 258.000000, d: 1.274689e-321)
xmm8 0000000000000000 (f: 0.000000, d: 0.000000e+00)
xmm9 0000000000000000 (f: 0.000000, d: 0.000000e+00)
xmm10 0000000000000000 (f: 0.000000, d: 0.000000e+00)
xmm11 0000000000000000 (f: 0.000000, d: 0.000000e+00)
xmm12 0000000000000000 (f: 0.000000, d: 0.000000e+00)
xmm13 0000000000000000 (f: 0.000000, d: 0.000000e+00)
xmm14 0000000000000000 (f: 0.000000, d: 0.000000e+00)
xmm15 0000000000000000 (f: 0.000000, d: 0.000000e+00)
Module=/usr/lib64/jvm/java-1_6_0-ibm-1.6.0/jre/lib/amd64/default/
libjclscar_24.so
Module_base_address=00002B4F3B71D000 Symbol=
sun_misc_Unsafe_getLong__Ljava_lang_Object_2J
Symbol_address=00002B4F3B76A5E8
Target=2_40_20120202_101568 (Linux 2.6.32.59-0.3-default)
CPU=amd64 (24 logical CPUs) (0x179e2b3000 RAM)
----------- Stack Backtrace -----------
sun_misc_Unsafe_getLong__Ljava_lang_Object_2J+0x41 (0x00002B4F3B76A629 [
libjclscar_24.so+0x4d629])

Any suggestions/ideas?

Thanks
Greg

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Greg Mowery) #2

On Thursday, October 17, 2013 10:30:06 AM UTC-4, Greg Mowery wrote:

I am doing some testing/POC code on moving a current SOLR solution to an
ElasticSeach based search. In testing, I am running into a problem when
trying to indexing a document.

OS: SUSE Linux Enterprise Server 11 (x86_64) running in a virtualized mode
java version: jdk1.6.0_29
es version: 0.90.5

I am using the transportclient in java:

address = CFactory.instance().getProperty("elastic.address");

 try
 {
   
   Settings settings = ImmutableSettings.settingsBuilder()
       .put("cluster.name", "esS1").build();

   client =    new TransportClient(settings);

 client.addTransportAddress(new InetSocketTransportAddress(address, 

9300));

No problems here

I then generate a map of fields/values.

if(indexableData == null)
indexableData = new HashMap<String,Object>();

indexableData.clear();

indexableData.put(IDocumentIndexableFields.TITLE, getTitle());
indexableData.put(IDocumentIndexableFields.AUTHORNAMES,getAuthorsForIndexing

());
indexableData.put(IDocumentIndexableFields.DOCUMENTID, getId());
indexableData.put(IDocumentIndexableFields.DOCUMENTNO, getDocumentNo
());
indexableData.put(IDocumentIndexableFields.CONFIGID, getConfigId().
toString());
int[] groups = getGroupIds(user);
if(groups != null)
indexableData.put(IDocumentIndexableFields.GROUPNO, groups);
indexableData.put(IDocumentIndexableFields.STACKID, user.getConfig().
getParameterValue(IConfigParameterName.PRODUCTION_STACK_ID));

return indexableData;

I then send the map to the client

Map fields = obj.getFieldData(user);
try
{
response = client.prepareIndex(root, obj.getObjName(),obj.
generateIndexId(user))
.setSource(fields)
.execute()
.actionGet();
}

The log from elasticsearch registers this:
[2013-10-17 09:05:32,885][DEBUG][action.index ] [Hijacker]
Sending mapping updated to master: index [s1m.dev] type [document]

Then I get a GPF

Unhandled exception
Type=Segmentation error vmState=0x00000000
J9Generic_Signal_Number=00000004 Signal_Number=0000000b Error_Value=
00000000 Signal_Code=00000080
Handler1=00002B4F399564C0 Handler2=00002B4F39CE67F0 InaccessibleAddress=
0000000000000000
RDI=17E600830001565A RSI=0000000001046EBE RAX=000000000000003A RBX=
000000000109C400
RCX=0000000002450880 RDX=17E600830001565A R8=17E600830001565A R9=
0000000000000164
R10=0000000000000000 R11=0000000000000002 R12=00000000006E3080 R13=
0000000002425DB4
R14=00002B4F39ABB160 R15=00002B4F7DED6F20
RIP=00002B4F3B76A629 GS=0000 FS=0000 RSP=00000000024507F8
EFlags=0000000000210206 CS=0033 RBP=0000000002445C00 ERR=0000000000000000
TRAPNO=000000000000000D OLDMASK=0000000000000000 CR2=0000000000000000
xmm0 0000000000000000 (f: 0.000000, d: 0.000000e+00)
xmm1 0000000000000000 (f: 0.000000, d: 0.000000e+00)
xmm2 ffff000000000000 (f: 0.000000, d: -nan)
xmm3 0000000002445c00 (f: 38034432.000000, d: 1.879151e-316)
xmm4 00002b4f84e36bd0 (f: 2229496832.000000, d: 2.352767e-310)
xmm5 00002b4f7ef53180 (f: 2129998208.000000, d: 2.352762e-310)
xmm6 00002b4f39abb160 (f: 967553408.000000, d: 2.352705e-310)
xmm7 0000000000000102 (f: 258.000000, d: 1.274689e-321)
xmm8 0000000000000000 (f: 0.000000, d: 0.000000e+00)
xmm9 0000000000000000 (f: 0.000000, d: 0.000000e+00)
xmm10 0000000000000000 (f: 0.000000, d: 0.000000e+00)
xmm11 0000000000000000 (f: 0.000000, d: 0.000000e+00)
xmm12 0000000000000000 (f: 0.000000, d: 0.000000e+00)
xmm13 0000000000000000 (f: 0.000000, d: 0.000000e+00)
xmm14 0000000000000000 (f: 0.000000, d: 0.000000e+00)
xmm15 0000000000000000 (f: 0.000000, d: 0.000000e+00)
Module=/usr/lib64/jvm/java-1_6_0-ibm-1.6.0/jre/lib/amd64/default/
libjclscar_24.so
Module_base_address=00002B4F3B71D000 Symbol=
sun_misc_Unsafe_getLong__Ljava_lang_Object_2J
Symbol_address=00002B4F3B76A5E8
Target=2_40_20120202_101568 (Linux 2.6.32.59-0.3-default)
CPU=amd64 (24 logical CPUs) (0x179e2b3000 RAM)
----------- Stack Backtrace -----------
sun_misc_Unsafe_getLong__Ljava_lang_Object_2J+0x41 (0x00002B4F3B76A629 [
libjclscar_24.so+0x4d629])

Any suggestions/ideas?

Thanks
Greg

This turned out to be a bug in IBM java. Upgrading to java 7 appears to
have fixed the issue.

Greg

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Alexander Reelsen) #3

Hey,

just for the archives: The Lucene project has a small wiki page, where it
shows several JVMs which result in problems, looks as if the IBM jvm is
featured there as well: http://wiki.apache.org/lucene-java/JavaBugs

Generally the simplest way is to run the oracle JDK, preferrably one of the
latest versions (however the current 1.7_40 release iirc can also cause
problems in some conditions)., and preferrably java 7 over 6 if your
environment permits.

--Alex

On Thu, Oct 17, 2013 at 6:44 PM, Greg Mowery greg.mowery@gmail.com wrote:

On Thursday, October 17, 2013 10:30:06 AM UTC-4, Greg Mowery wrote:

I am doing some testing/POC code on moving a current SOLR solution to an
ElasticSeach based search. In testing, I am running into a problem when
trying to indexing a document.

OS: SUSE Linux Enterprise Server 11 (x86_64) running in a virtualized mode
java version: jdk1.6.0_29
es version: 0.90.5

I am using the transportclient in java:

address = CFactory.instance().getPropert**y("elastic.address");

 try
 {

   Settings settings = ImmutableSettings.settingsBuil**der()
       .put("cluster.name", "esS1").build();

   client =    new TransportClient(settings);

 client.addTransportAddress(ne**w InetSocketTransportAddress(add**

ress, 9300));

No problems here

I then generate a map of fields/values.

if(indexableData == null)
indexableData = new HashMap<String,Object>();

indexableData.clear();

indexableData.put(IDocumentInd**exableFields.TITLE, getTitle());
indexableData.put(IDocumentInd**exableFields.AUTHORNAMES,getAuthorsForIndexing

());
indexableData.put(IDocumentIndexableFields.DOCUMENTID, getId());
indexableData.put(IDocumentInd
exableFields.DOCUMENTNO,getDocumentNo
());
indexableData.put(IDocumentIndexableFields.CONFIGID, getConfigId().
toString());
int[] groups = getGroupIds(user);
if(groups != null)
indexableData.put(IDocumentIn
dexableFields.GROUPNO, groups);
indexableData.put(IDocumentIndexableFields.STACKID, user.getConfig
().getParameterV
alue(IConfigParameterName.PROD**UCTION_STACK_ID));

return indexableData;

I then send the map to the client

Map fields = obj.getFieldData(user);
try
{
response = client.prepareIndex(root, obj.getObjName(),obj.generateI**
ndexId(user))
.setSource(fields)
.execute()
.actionGet();
}

The log from elasticsearch registers this:
[2013-10-17 09:05:32,885][DEBUG][action.**index ] [Hijacker]
Sending mapping updated to master: index [s1m.dev] type [document]

Then I get a GPF

Unhandled exception
Type=Segmentation error vmState=0x00000000
J9Generic_Signal_Number=00000004 Signal_Number=0000000b Error_Value=
00000000 Signal_Code=00000080
Handler1=00002B4F399564C0 Handler2=00002B4F39CE67F0 InaccessibleAddress=
0000000000
000000
RDI=17E600830001565A RSI=0000000001046EBE RAX=000000000000003A RBX=
000000000109C400
RCX=0000000002450880 RDX=17E600830001565A R8=17E600830001565A R9=
0000000000000164
R10=0000000000000000 R11=0000000000000002 R12=00000000006E3080 R13=
0000000002425DB4
R14=00002B4F39ABB160 R15=00002B4F7DED6F20
RIP=00002B4F3B76A629 GS=0000 FS=0000 RSP=00000000024507F8
EFlags=0000000000210206 CS=0033 RBP=0000000002445C00 ERR=0000000000000000
TRAPNO=000000000000000D OLDMASK=0000000000000000 CR2=0000000000000000
xmm0 0000000000000000 (f: 0.000000, d: 0.000000e+00)
xmm1 0000000000000000 (f: 0.000000, d: 0.000000e+00)
xmm2 ffff000000000000 (f: 0.000000, d: -nan)
xmm3 0000000002445c00 (f: 38034432.000000, d: 1.879151e-316)
xmm4 00002b4f84e36bd0 (f: 2229496832.000000, d: 2.352767e-310)
xmm5 00002b4f7ef53180 (f: 2129998208.000000, d: 2.352762e-310)
xmm6 00002b4f39abb160 (f: 967553408.000000, d: 2.352705e-310)
xmm7 0000000000000102 (f: 258.000000, d: 1.274689e-321)
xmm8 0000000000000000 (f: 0.000000, d: 0.000000e+00)
xmm9 0000000000000000 (f: 0.000000, d: 0.000000e+00)
xmm10 0000000000000000 (f: 0.000000, d: 0.000000e+00)
xmm11 0000000000000000 (f: 0.000000, d: 0.000000e+00)
xmm12 0000000000000000 (f: 0.000000, d: 0.000000e+00)
xmm13 0000000000000000 (f: 0.000000, d: 0.000000e+00)
xmm14 0000000000000000 (f: 0.000000, d: 0.000000e+00)
xmm15 0000000000000000 (f: 0.000000, d: 0.000000e+00)
Module=/usr/lib64/jvm/java-1_6_0-ibm-1.6.0/jre/lib/amd64/default/
libjclscar_24.so
Module_base_address=00002B4F3B71D000 Symbol=sun_misc_Unsafe_
getLong__Ljava_lang_Object_2J
Symbol_address=00002B4F3B76A5E**8
Target=2_40_20120202_101568 (Linux 2.6.32.59-0.3-default)
CPU=amd64 (24 logical CPUs) (0x179e2b3000 RAM)
----------- Stack Backtrace -----------
sun_misc_Unsafe_getLong__**Ljava_lang_Object_2J+0x41 (0x00002B4F3B76A629
[libjclscar_24.so+0x4d629])

Any suggestions/ideas?

Thanks
Greg

This turned out to be a bug in IBM java. Upgrading to java 7 appears to
have fixed the issue.

Greg

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Jörg Prante) #4

Current is Java 7u45, maybe this update is better than 7u40.

Jörg

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Greg Mowery) #5

Thanks all. Upgraded to 7u45 and the issue has gone away.

Greg

On Sunday, October 20, 2013 12:47:35 PM UTC-4, Jörg Prante wrote:

Current is Java 7u45, maybe this update is better than 7u40.

Jörg

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #6