Elk stucked when input data from local file


(Jlogan) #1

hi i wanted import my data to elasticsearch through logstash ,the logstash.conf is
`input {
file {
path => "/home/data/accounts.json"
}
}

output {
elasticsearch {
hosts => ["172.16.0.10:9200"]
index => "accounts"
}
}

but when i run this, just show
Sending Logstash's logs to /var/log/logstash which is now configured via log4j2.properties`
and stucked here,no any outputs,no errors show.
im so confused,could you help me ?
i just installed elasticsearch5.3, kibana5.3, logstash5.3, x-pack5.3


(Magnus Bäck) #2

Logstash is tailing the input file and waiting for more data to be added to it. Please read the file input documentation. Pay special attention to what's said about sincedb_path and start_position.


(Jlogan) #3

thanks,i read the file used the sincedb_path and start_position,but still the same problem.i don't know why this happened,i want know why,so i can solve this quickly,anyway thankyou for your reply


(Magnus Bäck) #4

So what did you try, exactly?


(Jlogan) #5

i tried sincedb_path="/dev/null" and start_position="beginning". also tried output to a local file, renamed the input filename...same situation...but i usedinput { stdin { } } output { stdout {} } in my conf ,it is right. so the problem is caused from the conf


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.