Enable Position Increments property not available

Hello,
I am trying to use the shingle token filter, and previously was using a
stop-filter with the enable_position_increments
property(http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/analysis-stop-tokenfilter.html).
This property was removed in 0.90.3 according to the documentation, and I
was wondering if there was another method to achieve the same
functionality? I currently can see unwanted characters in my facets, and
need to make sure that only expected results appear.

Thanks,
Christian Rohling

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e83b7f44-44f1-4cf9-9efb-1cf823cc5ecf%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

1 Like

Hi Christian, I looked into the issue and it appears there isn't really an
alternative at the moment. The property was removed because Lucene removed
the underlying functionality, since it can potentially break token streams
(usually in regards to synonyms). You can see the issue
here: https://issues.apache.org/jira/browse/LUCENE-4065

When I've used the parameter before, it was to remove underscores that were
generated due to a stop-word filter. If that's your case, you might
consider adding a pattern-replace filter to remove lone underscores. This
is admittedly a terrible hack, but it might work until Lucene sorts out the
underlying issue.

Sorry I don't have better news :frowning:
-Zach

On Wednesday, February 5, 2014 1:49:36 PM UTC-5, Christian Rohling wrote:

Hello,
I am trying to use the shingle token filter, and previously was using
a stop-filter with the enable_position_increments property(
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/analysis-stop-tokenfilter.html).
This property was removed in 0.90.3 according to the documentation, and I
was wondering if there was another method to achieve the same
functionality? I currently can see unwanted characters in my facets, and
need to make sure that only expected results appear.

Thanks,
Christian Rohling

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/7e43170c-bf21-4df8-a1a2-186c05c8ae7d%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Is there any progress on this issue?

On Thursday, February 6, 2014 4:38:27 PM UTC+2, Zachary Tong wrote:

Hi Christian, I looked into the issue and it appears there isn't really an
alternative at the moment. The property was removed because Lucene removed
the underlying functionality, since it can potentially break token streams
(usually in regards to synonyms). You can see the issue here:
https://issues.apache.org/jira/browse/LUCENE-4065

When I've used the parameter before, it was to remove underscores that
were generated due to a stop-word filter. If that's your case, you might
consider adding a pattern-replace filter to remove lone underscores. This
is admittedly a terrible hack, but it might work until Lucene sorts out the
underlying issue.

Sorry I don't have better news :frowning:
-Zach

On Wednesday, February 5, 2014 1:49:36 PM UTC-5, Christian Rohling wrote:

Hello,
I am trying to use the shingle token filter, and previously was using
a stop-filter with the enable_position_increments property(
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/analysis-stop-tokenfilter.html).
This property was removed in 0.90.3 according to the documentation, and I
was wondering if there was another method to achieve the same
functionality? I currently can see unwanted characters in my facets, and
need to make sure that only expected results appear.

Thanks,
Christian Rohling

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3f5f7d5a-be36-4f20-8c0e-88a771559fc3%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

1 Like