Enabling xpack security TLS

Just upgraded 3 node cluster (sandbox) to 7.15.2 Basic license
Following these instructions to enable security and ultimately tls transport communications.

directions say to enable security
-enabled security
-Elasticsearch fails to start and complains that I must enable tls
Transport SSL must be enabled if security is enabled on a [basic] license. Please set [xpack.security.transport.ssl.enabled] to [true]
-enabled tls
-Elasticsearch starts
-cluster can't see each other and therefore causes "Cause: master_not_discovered_exception" and spins
-connections to nodes fail
-without enabling xpack security you can't run the account password generator tool "./bin/Elasticsearch-setup-passwords auto" because it barks that you have to have xpack security enabled.
-still digging

Any help is appreciated

Welcome to our community! :smiley:

It'd be useful if you could share;

  • your config
  • your Elasticsearch logs

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.