ENOMEM error on ES


(Allen Chan) #1

Hi all,

I just moved to start using elasticsearch as a non-root user. I am getting
this error at startup

[2014-08-08 22:38:17,768][WARN ][common.jna ] Unable to lock
JVM memory (ENOMEM). This can result in part of the JVM being swapped out.
Increase RLIMIT_MEMLOCK (limit).

Does anyone have experience with this error? I upped the file descriptor
limit and confirmed it through the ES API and OS level.

I am running ES 1.3.1

Thanks!

$ java -version

java version "1.7.0_65"

OpenJDK Runtime Environment (rhel-2.5.1.2.el6_5-x86_64 u65-b17)

OpenJDK 64-Bit Server VM (build 24.65-b04, mixed mode)

$ ps -ef | grep -i elasticsearch

1101 21634 1 2 23:04 ? 00:00:04 /usr/bin/java -Xms256m
-Xmx1g -Xss256k -Djava.awt.headless=true -XX:+UseParNewGC
-XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75
-XX:+UseCMSInitiatingOccupancyOnly -XX:+HeapDumpOnOutOfMemoryError
-XX:+DisableExplicitGC -Delasticsearch
-Des.pidfile=/var/run/elasticsearch/elasticsearch.pid
-Des.path.home=/usr/share/elasticsearch -cp
:/usr/share/elasticsearch/lib/elasticsearch-1.3.1.jar:/usr/share/elasticsearch/lib/:/usr/share/elasticsearch/lib/sigar/
-Des.default.path.home=/usr/share/elasticsearch
-Des.default.path.logs=/var/log/elasticsearch
-Des.default.path.data=/var/lib/elasticsearch
-Des.default.path.work=/tmp/elasticsearch
-Des.default.path.conf=/etc/elasticsearch
org.elasticsearch.bootstrap.Elasticsearch

$ sudo cat /proc/21634/limits

Limit Soft Limit Hard Limit Units

Max cpu time unlimited unlimited seconds

Max file size unlimited unlimited bytes

Max data size unlimited unlimited bytes

Max stack size 10485760 unlimited bytes

Max core file size 0 unlimited bytes

Max resident set unlimited unlimited bytes

Max processes 1024 1356363
processes

Max open files 65535 65535 files

Max locked memory 65536 65536 bytes

Max address space unlimited unlimited bytes

Max file locks unlimited unlimited locks

Max pending signals 1356363 1356363 signals

Max msgqueue size 819200 819200 bytes

Max nice priority 0 0

Max realtime priority 0 0

Max realtime timeout unlimited unlimited us

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2c7d3f70-a5b4-486d-92a9-84680571fca4%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Jörg Prante) #2

This is a warning, not an error.

As you can see, you allowed only 65536 bytes(!) for memory locking. You can
set this to unlimited if you are on Linux OS with memory overcommit.

Jörg

On Mon, Aug 11, 2014 at 8:50 PM, allen chan allen.michael.chan@gmail.com
wrote:

Hi all,

I just moved to start using elasticsearch as a non-root user. I am getting
this error at startup

[2014-08-08 22:38:17,768][WARN ][common.jna ] Unable to
lock JVM memory (ENOMEM). This can result in part of the JVM being swapped
out. Increase RLIMIT_MEMLOCK (limit).

Does anyone have experience with this error? I upped the file descriptor
limit and confirmed it through the ES API and OS level.

I am running ES 1.3.1

Thanks!

$ java -version

java version "1.7.0_65"

OpenJDK Runtime Environment (rhel-2.5.1.2.el6_5-x86_64 u65-b17)

OpenJDK 64-Bit Server VM (build 24.65-b04, mixed mode)

$ ps -ef | grep -i elasticsearch

1101 21634 1 2 23:04 ? 00:00:04 /usr/bin/java -Xms256m
-Xmx1g -Xss256k -Djava.awt.headless=true -XX:+UseParNewGC
-XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75
-XX:+UseCMSInitiatingOccupancyOnly -XX:+HeapDumpOnOutOfMemoryError
-XX:+DisableExplicitGC -Delasticsearch
-Des.pidfile=/var/run/elasticsearch/elasticsearch.pid
-Des.path.home=/usr/share/elasticsearch -cp
:/usr/share/elasticsearch/lib/elasticsearch-1.3.1.jar:/usr/share/elasticsearch/lib/:/usr/share/elasticsearch/lib/sigar/
-Des.default.path.home=/usr/share/elasticsearch
-Des.default.path.logs=/var/log/elasticsearch
-Des.default.path.data=/var/lib/elasticsearch
-Des.default.path.work=/tmp/elasticsearch
-Des.default.path.conf=/etc/elasticsearch
org.elasticsearch.bootstrap.Elasticsearch

$ sudo cat /proc/21634/limits

Limit Soft Limit Hard Limit Units

Max cpu time unlimited unlimited seconds

Max file size unlimited unlimited bytes

Max data size unlimited unlimited bytes

Max stack size 10485760 unlimited bytes

Max core file size 0 unlimited bytes

Max resident set unlimited unlimited bytes

Max processes 1024 1356363
processes

Max open files 65535 65535 files

Max locked memory 65536 65536 bytes

Max address space unlimited unlimited bytes

Max file locks unlimited unlimited locks

Max pending signals 1356363 1356363 signals

Max msgqueue size 819200 819200 bytes

Max nice priority 0 0

Max realtime priority 0 0

Max realtime timeout unlimited unlimited us

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/2c7d3f70-a5b4-486d-92a9-84680571fca4%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/2c7d3f70-a5b4-486d-92a9-84680571fca4%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoHwxyLPxEPiHUz-LVdR5RtRudCg-zFKJk1nLPWK5oi%2B5Q%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3