Enterprise search installation gives API key error

Hi,

I'm trying to install Elastic Enterprise Search on my system.

I have added necessary settings in elasticsearch.yml, enterprise-search.yml and kibana.yml.

But when i run,

ENT_SEARCH_DEFAULT_PASSWORD=PASSWORD bin/enterprise-search

I get the below error:
Elasticsearch API key service must be enabled. It is enabled automatically when you configure Elasticsearch to use TLS on the HTTP interface.Alternatively, you can explicitly enable the setting within Elasticsearch by opening config/elasticsearch.yml and adding:xpack.security.authc.api_key.enabled: true

But I have added xpack.security.authc.api_key.enabled: true to my elasticsearch.yml file.
Have restarted all services
Don't get why still I'm this is giving error.
Any suggestions for this?

Hi Sandeep, thanks for trying out Enterprise Search.

Since the Enterprise Search solution requires security to be enabled for Elasticsearch (including the Elasticsearch API key service), you'll also have to add xpack.security.enabled: true to your elasticsearch.yml if you haven't already.

Hi Casey,
@casey

I have enabled xpack.security.enabled: true in my elasticsearch.yml.
Still I'm getting the error.