Environment variables not set in logstash 5.2

I'm following the instructions given here, but unable to get it to work.

This is the error message I get when I run logstas,

nd "port" pre-2.0\n\tdocument_type => "tm"\n\tdocument_id => "%{id}"\n ssl => "true"\n index => "${LANG_INDEX}"\n manage_template => false\n }\n}\n\n", :reason=>"Cannot evaluate ${LANG_INDEX}. Environment variable LANG_INDEX is not set and there is no default value given."}

How are you setting the environment variable? How are you starting Logstash?

Setting the environment variable on command line as follows,

export LANG_INDEX="en-us_th-th"

And I start logstash as follows,

/usr/share/logstash/bin/logstash -f segments.conf

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.