Erreur de connexion entre elasticsearch et spring boot application


(salma) #1

Bonjour,
je suis débutante en elasticsearch, j'ai installée elasticsearch et je souhaite faire des requête avec mon application spring boot , le probleme que la connexion entre l'application et elasticsearch est échouée
le problème que j'ai utilisée transport client mais les donnees sont stockés dans un node et n'est pas affichée dans localhost:9200

ElasticsearchConfiguration:

public class EsConfig {

    @Value("${spring.data.elasticsearch.properties..host}")
    private String EsHost;

    @Value("${spring.data.elasticsearch.properties.port}")
    private int EsPort;

    @Value("${spring.data.elasticsearch.properties.clustername}")
    private String EsClusterName
    @Bean
    public Client client() throws Exception {

        Settings esSettings = Settings.settingsBuilder()
                .put("cluster.name", EsClusterName)
                .build();
        return TransportClient.builder()
                .settings(esSettings)
                .build()
                .addTransportAddress(
				  new InetSocketTransportAddress(InetAddress.getByName(EsHost), EsPort));
    }

    @Bean
    public ElasticsearchOperations elasticsearchTemplate() throws Exception {
        return new ElasticsearchTemplate(client());
    }
}

L'affichage dans le console:
client.type = node
cluster.name = elasticsearch
clustername = mkyong-cluster
host = localhost
http.enabled = false
name = Lonnie Thompson Lincoln
node.local = true
path.home = target/elastic-embedded
path.logs = C:/Project/workspace/workspace1/backend-project/target/elastic-embedded/logs
port = 9300

mais rien ni afficher dans localhost:9200
je me demande quelle est mon erreur pour stocker les données dans elasticserach server?

merci d'avance pour votre aide.


(David Pilato) #2

Il arrive très souvent que spring-data-elasticsearch ne soit pas compatible avec elasticsearch.

Vérifie les versions de part et d'autre.


(salma) #3

Bonjour dadoonet,
j'ai utilisée spring boot starter data elasticserach : 1.5.2 et elasticsearch 5.3.0 si il est un problème de version pouquoi il crée le cluster name et tout?
merci


(David Pilato) #4

Je ne sais pas. Je n'utilise pas Spring boot. Je ne fais que rapporter ici ce que j'ai très très souvent vu sur le forum #elasticsearch


(Val Crettaz) #5

Si tu mets http.enabled à false, c'est normal que tu ne puisses pas accéder à http://localhost:9200. Essaye de le mettre à true et regarde si ça fonctionne mieux.

D'autre part il semble que tu as une typo dans la ligne suivante (il y a deux points avant host)
@Value("${spring.data.elasticsearch.properties..host}")


(salma) #6

@Value("${spring.data.elasticsearch.properties..host}")
j'ai le corrige mais le meme probleme mais pour http.enable=false c'est le console qui l'affiche comment je peux le modifie ?
merci


(Val Crettaz) #7

Change ta configuration comme ceci:

    Settings esSettings = Settings.settingsBuilder()
            .put("cluster.name", EsClusterName)
            .put("http.enabled", true)               <---- ajoute cette ligne
            .build();

(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.