Error adding percolate with metadata

Kimchy: We've chatted about this on IRC and I went about a complete
reconstruction with a fresh install of elasticsearch 0.18.4 on my
local machine and proceeded to setup the box as I have in production
to reproduce this error:

{"error":"RemoteTransportException[[Ghost Rider][inet[/
192.168.252.136:9303]][indices/index/shard/index]]; nested:
ElasticSearchIllegalArgumentException[query must be provided for
percolate request]; ","status":400}

You can follow the recreation here: https://gist.github.com/1394364

Any help appreciated....I had tried the commands against 0.17.8
without having defined the mappings and it worked....not sure if they
play a role or not.

Thanks

Keith

Thanks for the repro, found the problem, opened an issue:
https://github.com/elasticsearch/elasticsearch/issues/1505.

On Fri, Nov 25, 2011 at 10:34 PM, Mehtryx keith@benedicthome.com wrote:

Kimchy: We've chatted about this on IRC and I went about a complete
reconstruction with a fresh install of elasticsearch 0.18.4 on my
local machine and proceeded to setup the box as I have in production
to reproduce this error:

{"error":"RemoteTransportException[[Ghost Rider][inet[/
192.168.252.136:9303]][indices/index/shard/index]]; nested:
ElasticSearchIllegalArgumentException[query must be provided for
percolate request]; ","status":400}

You can follow the recreation here: https://gist.github.com/1394364

Any help appreciated....I had tried the commands against 0.17.8
without having defined the mappings and it worked....not sure if they
play a role or not.

Thanks

Keith

Hi Kimchy,

I am getting the same error. The ES version which I am using is 0.20.6. Can
you tell me whether the bug fixed in this version?

thanks

On Sunday, November 27, 2011 7:44:42 AM UTC-8, kimchy wrote:

Thanks for the repro, found the problem, opened an issue:
https://github.com/elasticsearch/elasticsearch/issues/1505.

On Fri, Nov 25, 2011 at 10:34 PM, Mehtryx <ke...@benedicthome.com<javascript:>

wrote:

Kimchy: We've chatted about this on IRC and I went about a complete
reconstruction with a fresh install of elasticsearch 0.18.4 on my
local machine and proceeded to setup the box as I have in production
to reproduce this error:

{"error":"RemoteTransportException[[Ghost Rider][inet[/
192.168.252.136:9303]][indices/index/shard/index]]; nested:
ElasticSearchIllegalArgumentException[query must be provided for
percolate request]; ","status":400}

You can follow the recreation here: https://gist.github.com/1394364

Any help appreciated....I had tried the commands against 0.17.8
without having defined the mappings and it worked....not sure if they
play a role or not.

Thanks

Keith

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.